aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/libconnman-qt/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/libconnman-qt/APKBUILD b/testing/libconnman-qt/APKBUILD
new file mode 100644
index 0000000000..24f67ce468
--- /dev/null
+++ b/testing/libconnman-qt/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=libconnman-qt
+pkgver=1.2.32
+pkgrel=0
+pkgdesc="Qt bindings for ConnMan"
+url="https://git.sailfishos.org/mer-core/libconnman-qt"
+arch="all"
+license="Apache-2.0"
+depends="connman"
+depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev"
+makedepends="$depends_dev"
+subpackages="$pkgname-dev"
+source="https://git.sailfishos.org/mer-core/libconnman-qt/-/archive/$pkgver/libconnman-qt-$pkgver.tar.gz"
+
+build() {
+ qmake-qt5
+ make
+}
+
+package() {
+ INSTALL_ROOT="$pkgdir" make install
+}
+
+sha512sums="309041a7510de16e1355dadddd7888f1606f92ef4b847d145c97c5ac1765d664e8ad5cb88c818d037973dc3ff348103246066296db890d0cf3f2ebc7f0ea8015 libconnman-qt-1.2.32.tar.gz"