aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/libuser/APKBUILD37
1 files changed, 20 insertions, 17 deletions
diff --git a/testing/libuser/APKBUILD b/testing/libuser/APKBUILD
index ca7fa794cd..166fd90bdb 100644
--- a/testing/libuser/APKBUILD
+++ b/testing/libuser/APKBUILD
@@ -2,45 +2,48 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=libuser
pkgver=0.62
-pkgrel=1
+pkgrel=2
pkgdesc="A standardized interface for manipulating and administering user and group accounts"
url="https://pagure.io/libuser"
arch="all"
-license="LGPL"
-depends="python2"
-makedepends="python2-dev glib-dev popt-dev libexecinfo-dev linux-pam-dev
-autoconf automake libtool"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang py2-$pkgname:_py"
-source="https://releases.pagure.org/$pkgname/$pkgname-$pkgver.tar.xz
+license="LGPL-2.0-or-later"
+depends="python3"
+makedepends="python3-dev glib-dev popt-dev libexecinfo-dev linux-pam-dev
+ autoconf automake libtool"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang py3-$pkgname:_py"
+source="https://releases.pagure.org/libuser/libuser-$pkgver.tar.xz
0001-Check-for-issetugid.patch
- 0002-remove-unused-execinfo.h.patch"
-builddir="$srcdir/$pkgname-$pkgver"
+ 0002-remove-unused-execinfo.h.patch
+ "
-build() {
- cd "$builddir"
+prepare() {
+ default_prepare
autoreconf -vif
+}
+
+build() {
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--sbindir=/usr/bin \
--with-python \
--disable-gtk-doc-html \
- --disable-rpath
- sed -i 's/SUBDIRS = po docs/SUBDIRS = po/' Makefile
- make || return 1
+ --disable-rpath \
+ --with-python=/usr/bin/python3
+ sed -i 's/SUBDIRS = po docs/SUBDIRS = po/' Makefile
+ make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
_py() {
cd "$builddir"
- pkgdesc="Python2 bindings for $pkgname"
+ pkgdesc="Python3 bindings for $pkgname"
depends="$pkgname"
mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir""/usr/lib/python2.7" "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/python3* "$subpkgdir"/usr/lib
}
sha512sums="bc2f68456eae5912ac236192e97a3d66d5fa782520eff48d44d391c1ade590e001d821d7a93499e2391d0310cf03f60e4411f045f6ee3301af4e174d9ddc8450 libuser-0.62.tar.xz