aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/wslu/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/wslu/APKBUILD b/testing/wslu/APKBUILD
new file mode 100644
index 0000000000..ae7611357c
--- /dev/null
+++ b/testing/wslu/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Patrick Wu <wotingwu@live.com>
+# Contributor: Patrick Wu <wotingwu@live.com>
+pkgname=wslu
+pkgver=2.3.2
+pkgrel=0
+pkgdesc="A collection of utilities for Windows 10 Linux Subsystems"
+url="https://github.com/wslutilities/wslu"
+arch="noarch"
+license="GPL-3.0-or-later"
+depends="bc bash-completion imagemagick"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/wslutilities/wslu/archive/v$pkgver.tar.gz"
+options="!check" #tests can be only run on a distro running on WSL(Windows Subsystems for Linux) environment, hence disabled
+
+build() {
+ make
+}
+
+check() {
+ make test
+}
+
+package() {
+ install -Dm 555 docs/* -t "$pkgdir"/usr/share/man/man1/
+ install -Dm 755 out/* -t "$pkgdir"/usr/bin/
+ install -Dm 555 src/etc/* -t "$pkgdir"/usr/share/wslu/
+}
+
+sha512sums="a99314e67713aeba8c4a93f7ff03e9e036d3942b5a90bbaa366a3af62541af2842490f91fb7a957ab821de2ba2882b409e0e3f4f37db7a332ee941a75e524dba wslu-2.3.2.tar.gz"