aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/py-flake8-blind-except/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-flake8-blind-except/APKBUILD b/testing/py-flake8-blind-except/APKBUILD
new file mode 100644
index 0000000000..04080f3e60
--- /dev/null
+++ b/testing/py-flake8-blind-except/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flake8-blind-except
+_pkgname=flake8-blind-except
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Extension for flake8 which checks for blind except: statements"
+url="https://github.com/elijahandrews/flake8-blind-except"
+arch="noarch"
+license="MIT"
+depends="python py-flake8"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="a76ae6603b53c230ad81f9dea27c6bbb flake8-blind-except-0.1.0.tar.gz"
+sha256sums="a8599a48d9fff490ce4fa2c6a60ca876c39cc6c107f58068eb831079266b650b flake8-blind-except-0.1.0.tar.gz"
+sha512sums="4fc3d284309fdb12eff7c50710b25958d180dfee1f34e5bcd48d08ee5310514806fc972ca0d516053b25327d84476d7e6badf6ca2e709c3c888239004647501f flake8-blind-except-0.1.0.tar.gz"