aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-humanhash3/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/py3-humanhash3/APKBUILD b/testing/py3-humanhash3/APKBUILD
new file mode 100644
index 0000000000..1bf5013860
--- /dev/null
+++ b/testing/py3-humanhash3/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Bart Ribberse <bribbers@disroot.org>
+# Maintainer: Bart Ribberse <bribbers@disroot.org>
+pkgname=py3-humanhash3
+pkgver=0.0.6
+pkgrel=0
+pkgdesc="Human-readable representations of digests"
+url="https://github.com/blag/humanhash"
+arch="noarch"
+license="Unlicense"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://pypi.python.org/packages/source/h/humanhash3/humanhash3-$pkgver.tar.gz"
+options="!check" # No tests
+builddir="$srcdir/humanhash3-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="2eca066915756d60df48f0b5ee7c7fce508d7b5f5e04c94ed46c4ac2e30eb2dccdc1f6eec183512bdd557401c8e4c68110d39db4ef30a61884f45cb0e663579f humanhash3-0.0.6.tar.gz"