aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/go/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/testing/go/APKBUILD b/testing/go/APKBUILD
index b9cbee4b28..6bfe138b9b 100644
--- a/testing/go/APKBUILD
+++ b/testing/go/APKBUILD
@@ -4,7 +4,7 @@ pkgver=1.2.1
pkgrel=0
pkgdesc="Go programming language compiler"
url="http://www.golang.org/"
-arch="x86_64"
+arch="x86 x86_64"
license="BSD"
depends=""
depends_dev=""
@@ -42,6 +42,8 @@ build() {
export GOROOT="$_builddir"
export GOBIN="$GOROOT"/bin
export GOROOT_FINAL=/usr/lib/go
+ # ccache breaks build for some reason
+ unset CC
case "$CARCH" in
x86) GOARCH=386;;