aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/crystal/APKBUILD4
-rw-r--r--testing/crystal/paxmark.patch22
2 files changed, 25 insertions, 1 deletions
diff --git a/testing/crystal/APKBUILD b/testing/crystal/APKBUILD
index 1fc93b42a9..f11d415796 100644
--- a/testing/crystal/APKBUILD
+++ b/testing/crystal/APKBUILD
@@ -11,7 +11,7 @@ url="https://crystal-lang.org/"
arch="x86_64 aarch64"
license="Apache-2.0"
depends="gc-dev libatomic_ops libevent-dev libxml2-dev gcc gmp-dev pcre-dev yaml-dev"
-checkdepends="openssl-dev readline-dev zlib-dev"
+checkdepends="openssl-dev paxmark readline-dev zlib-dev"
makedepends="llvm$_llvmver-dev ${BUILD_STATIC:+"llvm$_llvmver-static"}"
subpackages="$pkgname-doc
$pkgname-bash-completion:bashcomp:noarch
@@ -23,6 +23,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/crystal-lang/$pkgname/archiv
makefile-shell.patch
fix-makefile-stderr-redirect.patch
makefile-allow-extra-flags.patch
+ paxmark.patch
aarch64-linux-musl.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -125,4 +126,5 @@ d6ed122a5ddb4e1ea772357cd3115dcf8cd92a75f973b6f7e4b8b6135fb4123fb98334495f6f312d
2a81b6eaeb934ef5d4435a80a346425a760a602d04bccc89068dde7ed48a6099c4ea59a291f444127e91e81acde0ee42d857481041869cf6094a2e29f0de184a makefile-shell.patch
2f995903093da9af4263bf2d7fde75715a114b02b74ba26c8290d7b20042be8a2db305a2ea144925f054354f6f6a430750d19fa036bf764562dedb56da12866a fix-makefile-stderr-redirect.patch
d1641f538cb1ae9f817b57e19800b0af91e3723c752fba38b2644b8acc66d80862c6bef22194f1f4c64ae7d8393c2772f0a0ea0a76a199151ef8c74c686ea49f makefile-allow-extra-flags.patch
+dec4ed7abfd215eec825bed97b1e40bf3aa8bd959a4ec7153ea1bc51d409d892ebec19ddb0372e3a543e74c7018aca0c1f3cf956fa1d95efb946c8c3417c8749 paxmark.patch
0252e850b79d622fe69329fac3653128b1cc0108961c928a9efa8fa5df1bce13692b6a520697c45c37791a9e6547d5ec7f0f11905e8299902055ab3dbdfd7556 aarch64-linux-musl.patch"
diff --git a/testing/crystal/paxmark.patch b/testing/crystal/paxmark.patch
new file mode 100644
index 0000000000..db6efd89db
--- /dev/null
+++ b/testing/crystal/paxmark.patch
@@ -0,0 +1,22 @@
+Make tests run on Grsecurity system. This patch is downstream only.
+
+--- a/Makefile
++++ b/Makefile
+@@ -104,14 +104,17 @@
+ $(O)/all_spec: $(DEPS) $(SOURCES) $(SPEC_SOURCES)
+ @mkdir -p $(O)
+ $(BUILD_PATH) ./bin/crystal build $(FLAGS) -o $@ spec/all_spec.cr
++ paxmark m $(O)/all_spec
+
+ $(O)/std_spec: $(DEPS) $(SOURCES) $(SPEC_SOURCES)
+ @mkdir -p $(O)
+ $(BUILD_PATH) ./bin/crystal build $(FLAGS) -o $@ spec/std_spec.cr
++ paxmark m $(O)/std_spec
+
+ $(O)/compiler_spec: $(DEPS) $(SOURCES) $(SPEC_SOURCES)
+ @mkdir -p $(O)
+ $(BUILD_PATH) ./bin/crystal build $(FLAGS) -o $@ spec/compiler_spec.cr
++ paxmark m $(O)/compiler_spec
+
+ $(O)/crystal: $(DEPS) $(SOURCES)
+ @mkdir -p $(O)