aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/lua-fifo/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/testing/lua-fifo/APKBUILD b/testing/lua-fifo/APKBUILD
new file mode 100644
index 0000000000..6685e15496
--- /dev/null
+++ b/testing/lua-fifo/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=lua-fifo
+_pkgname=fifo.lua
+pkgver=0.2
+pkgrel=0
+pkgdesc="FIFO library for Lua"
+url="https://github.com/daurnimator/fifo.lua"
+arch="noarch"
+license="MIT"
+checkdepends="lua-busted"
+subpackages=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/daurnimator/$_pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+# luajit is not available for selected arches
+case "$CARCH" in
+ s390x) _luajit="";;
+ *) checkdepends="$checkdepends luajit" _luajit="jit";;
+esac
+
+_luaversions="5.1 5.2 5.3"
+for _v in $_luaversions; do
+ subpackages="$subpackages lua$_v-${pkgname#lua-}:_subpackage"
+ checkdepends="$checkdepends lua$_v"
+done
+
+check() {
+ cd "$builddir"
+
+ local lver; for lver in $_luaversions $_luajit; do
+ msg "Testing on lua$lver"
+ lua$lver /usr/bin/busted
+ done
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_subpackage() {
+ local lver="${subpkgname:3:3}"
+ pkgdesc="$pkgdesc $lver"
+ depends="lua$lver"
+ install_if="$pkgname=$pkgver-r$pkgrel lua$lver"
+
+ cd "$builddir"
+ install -D -m 644 fifo.lua "$subpkgdir"/usr/share/lua/$lver/fifo.lua
+}
+
+sha512sums="db2e0d2117c70ab0daa6e83141b95f198689e6568aab51e8300ca5577c1a517de249b9514ad8a3476239da3d9bceb699726ead913126817c0801f7ec5d419306 lua-fifo-0.2.tar.gz"