aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-arrow/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/testing/py3-arrow/APKBUILD b/testing/py3-arrow/APKBUILD
index 6b0a6972f5..5690fca204 100644
--- a/testing/py3-arrow/APKBUILD
+++ b/testing/py3-arrow/APKBUILD
@@ -2,14 +2,15 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-arrow
_pkgname=arrow
-pkgver=0.14.2
-pkgrel=1
+pkgver=0.14.5
+pkgrel=0
pkgdesc="Python3 library to create and manipulate dates, times, and timestamps"
url="https://arrow.readthedocs.io/"
arch="noarch"
license="Apache-2.0"
depends="py3-dateutil"
makedepends="py3-setuptools"
+checkdepends="py3-tz py3-simplejson"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -20,8 +21,12 @@ build() {
python3 setup.py build
}
+check() {
+ python3 setup.py test
+}
+
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="68c28e363de180f606e874076a9107b5214d8973e4bb9cdab639c5e30efe29e69cf97ca4aa1372f8da116dc3a518f2e4f8bc00807d64091ac922122288cfd31b arrow-0.14.2.tar.gz"
+sha512sums="2b2fa23ad565b1c85728aadb997dba30726b61c666a852f84be547254e54a23aaf20c9eda73e78246dcbb68d46954e035c66b44d4fcd5e5404bab2ebd4e81dc8 arrow-0.14.5.tar.gz"