aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/mblaze/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/testing/mblaze/APKBUILD b/testing/mblaze/APKBUILD
index 3debcad8fd..0f1289a17e 100644
--- a/testing/mblaze/APKBUILD
+++ b/testing/mblaze/APKBUILD
@@ -10,9 +10,10 @@ license="CC0-1.0"
depends=""
depends_dev=""
makedepends=""
+checkdepends="perl-utils"
install=""
subpackages="$pkgname-doc"
-options="!check"
+options="!check" # currently fail on the builder
source="$pkgname-$pkgver.tar.gz::https://github.com/chneukirchen/$pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
@@ -20,6 +21,10 @@ build() {
make CFLAGS="$CFLAGS" -C "$builddir"
}
+check() {
+ make -C "$builddir" check
+}
+
package() {
cd "$builddir"
make PREFIX="/usr" DESTDIR="$pkgdir" install