aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/tuptime/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/tuptime/APKBUILD b/testing/tuptime/APKBUILD
new file mode 100644
index 0000000000..596ebcdbdb
--- /dev/null
+++ b/testing/tuptime/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: Roberto Oliveira <robertoguimaraes8@gmail.com>
+# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
+pkgname=tuptime
+pkgver=3.4.2
+pkgrel=0
+pkgdesc="Report the historical and statistical real time of the system"
+url="https://github.com/rfrail3/tuptime"
+arch="noarch"
+license="GPL-2.0-only"
+depends="python3"
+subpackages="$pkgname-doc $pkgname-openrc"
+options="!check"
+source="$pkgname-$pkgver.tar.gz::https://github.com/rfrail3/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+package() {
+ cd "$builddir"
+ install -Dm775 "src/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "src/man/$pkgname.1" "$pkgdir/usr/share/man/man1/$pkgname.1"
+ install -Dm755 "src/openrc/$pkgname" "$pkgdir/etc/init.d/$pkgname"
+}
+
+sha512sums="c90e11a7d5dbee83325d4793316ccfa46b3f5ebe0914b6100757412b92446367070dca25b7fed3f4b7d8f08565dfc7c4e4e4027206b9dcfbb5b8942d36d94938 tuptime-3.4.2.tar.gz"