aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/cantata/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/cantata/APKBUILD')
-rw-r--r--unmaintained/cantata/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/unmaintained/cantata/APKBUILD b/unmaintained/cantata/APKBUILD
new file mode 100644
index 0000000000..71eebd37b1
--- /dev/null
+++ b/unmaintained/cantata/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Olivier Mauras <olivier@mauras.ch>
+# Maintainer:
+pkgname=cantata
+pkgver=1.5.2
+pkgrel=0
+pkgdesc="Qt based graphical client for MPD"
+url="https://code.google.com/p/cantata/"
+arch="all"
+license="GPLv3"
+depends=""
+depends_dev="qt-dev ffmpeg-dev taglib-dev mpg123-dev"
+makedepends="cmake $depends_dev"
+install=""
+subpackages=""
+source="$pkgname-$pkgver.tar.bz2::https://drive.google.com/uc?export=download&id=0Bzghs6gQWi60LV9rM3RMQk85Z1E"
+
+_builddir=$srcdir/$pkgname-$pkgver
+prepare() {
+ # Apply patches
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ mkdir build
+ cd build
+ cmake ..
+ make
+}
+
+package() {
+ cd "$_builddir/build"
+ make DESTDIR="$pkgdir" install || return 1
+ mv $pkgdir/usr/local/share/* $pkgdir/usr/share/
+ rm -r $pkgdir/usr/local
+}
+
+md5sums="0b29d30f1b03ecac23eb608309fbeaa1 cantata-1.5.2.tar.bz2"
+sha256sums="4de985b74597c4c3936982437ea562711d08c37d318b61e04f5c07af55f52c5f cantata-1.5.2.tar.bz2"
+sha512sums="84314758a936d5795a05cade68fe86df90c83b7fae78152bd60ae8b77d3cb71db6e37f0e30d49aba60b5205aea794729357051819d2d806e0a21701a1e0c78ab cantata-1.5.2.tar.bz2"
+