aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/chntpw/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/chntpw/APKBUILD')
-rw-r--r--unmaintained/chntpw/APKBUILD29
1 files changed, 7 insertions, 22 deletions
diff --git a/unmaintained/chntpw/APKBUILD b/unmaintained/chntpw/APKBUILD
index f95508d291..e878a787f6 100644
--- a/unmaintained/chntpw/APKBUILD
+++ b/unmaintained/chntpw/APKBUILD
@@ -1,40 +1,25 @@
-# Contributor:
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=chntpw
pkgver=140201
-pkgrel=0
+pkgrel=1
pkgdesc="Change passwords in Windows SAM files"
url="http://pogostick.net/~pnh/ntpasswd/"
arch="all"
license="GPL2"
-depends=""
-depends_dev=""
-makedepends="$depends_dev openssl-dev"
-install=""
-subpackages=""
+makedepends="libressl-dev"
source="http://pogostick.net/~pnh/ntpasswd/$pkgname-source-$pkgver.zip
- stdint.patch
- "
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+ stdint.patch"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
make CC="${CC:-gcc}" CFLAGS="$CFLAGS -DUSEOPENSSL" LIBS="-lcrypto" \
chntpw cpnt reged || return 1
}
package() {
- cd "$_builddir"
+ cd "$builddir"
install -d "$pkgdir"/usr/bin
install chntpw cpnt reged "$pkgdir"/usr/bin/
}