aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/chntpw/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/chntpw/APKBUILD')
-rw-r--r--unmaintained/chntpw/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/unmaintained/chntpw/APKBUILD b/unmaintained/chntpw/APKBUILD
new file mode 100644
index 0000000000..f95508d291
--- /dev/null
+++ b/unmaintained/chntpw/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor:
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=chntpw
+pkgver=140201
+pkgrel=0
+pkgdesc="Change passwords in Windows SAM files"
+url="http://pogostick.net/~pnh/ntpasswd/"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev=""
+makedepends="$depends_dev openssl-dev"
+install=""
+subpackages=""
+source="http://pogostick.net/~pnh/ntpasswd/$pkgname-source-$pkgver.zip
+ stdint.patch
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make CC="${CC:-gcc}" CFLAGS="$CFLAGS -DUSEOPENSSL" LIBS="-lcrypto" \
+ chntpw cpnt reged || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -d "$pkgdir"/usr/bin
+ install chntpw cpnt reged "$pkgdir"/usr/bin/
+}
+
+md5sums="d60bc657206b07ad84d926649d6417dc chntpw-source-140201.zip
+7219b4f860212e85de39ba1937e2c296 stdint.patch"
+sha256sums="96e20905443e24cba2f21e51162df71dd993a1c02bfa12b1be2d0801a4ee2ccc chntpw-source-140201.zip
+9d392cdf598d4a9e9ddd3ae1b538ed1d8bd63fb27e23d4e4c9b13110b808a723 stdint.patch"
+sha512sums="a26d747f6e077d1bb3e9b8077781f8c37dd978e07b7426495862f15c9004572b706c34736fc4d1ed8856b1a43335d726b4d87c688f7f9a11fd6cc3a74d71a7fa chntpw-source-140201.zip
+3ed747119d125b3e4dc8dbb2a697d411ef2f4403ec84c60177d8e35389bc695bb0c65f7aa4314ca320ffceec87e60e2a0c81d52544b90463fe23aa7d4a50df67 stdint.patch"