aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/cowpatty/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/cowpatty/APKBUILD')
-rw-r--r--unmaintained/cowpatty/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/unmaintained/cowpatty/APKBUILD b/unmaintained/cowpatty/APKBUILD
new file mode 100644
index 0000000000..1c630ab1e0
--- /dev/null
+++ b/unmaintained/cowpatty/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=cowpatty
+pkgver=4.3
+pkgrel=0
+pkgdesc="Attacking WPA/WPA2-PSK exchanges"
+url="http://www.willhackforsushi.com/Cowpatty.html"
+arch="all"
+license="GPL2+"
+depends=""
+depends_dev=""
+makedepends="libpcap-dev openssl-dev"
+install=""
+subpackages=""
+source="http://www.willhackforsushi.com/code/$pkgname/$pkgver/$pkgname-$pkgver.tgz
+ makefile.patch"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir" BINDIR=/usr/bin || return 1
+}
+
+md5sums="deccac0763a05ef7014107d347bf9190 cowpatty-4.3.tgz
+0c4e93c53b0356a5513d4a2dd798815d makefile.patch"