aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/edje
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/edje')
-rw-r--r--unmaintained/edje/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/unmaintained/edje/APKBUILD b/unmaintained/edje/APKBUILD
new file mode 100644
index 0000000000..ac753c2a77
--- /dev/null
+++ b/unmaintained/edje/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=edje
+pkgver=1.7.9
+pkgrel=0
+pkgdesc="Enlightenment's graphical layout and animation library"
+url="http://trac.enlightenment.org/e/wiki/Edje"
+arch="all"
+license="BSD"
+depends=""
+depends_dev="lua-dev eina-dev eet-dev embryo-dev ecore-dev evas-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://download.enlightenment.org/releases/edje-$pkgver.tar.gz"
+
+_builddir="$srcdir"/edje-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="49152d8636aefcd028af0f97483391ef edje-1.7.9.tar.gz"
+sha256sums="dac12e5fd81ab303151bec6742971b63f2de577ef940ed0b6af20419130300ab edje-1.7.9.tar.gz"
+sha512sums="ffa0e0e0b3f121b32c5df663587df3ae63fd7f0bb3ce5ba5b8db5ee40a9bbcc1d9c4cb74b8efc4119aa739b81d77cf95ef451c3f58698645ef8107a0028bca63 edje-1.7.9.tar.gz"