aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/emotion
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/emotion')
-rw-r--r--unmaintained/emotion/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/unmaintained/emotion/APKBUILD b/unmaintained/emotion/APKBUILD
new file mode 100644
index 0000000000..7bdde8954b
--- /dev/null
+++ b/unmaintained/emotion/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=emotion
+pkgver=1.7.9
+pkgrel=0
+pkgdesc="Emotion, video and audio codec API"
+url="http://trac.enlightenment.org/e/wiki/Emotion"
+arch="all"
+license="BSD"
+depends=""
+depends_dev="ecore-dev evas-dev eet-dev eina-dev edje-dev eio-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://download.enlightenment.org/releases/emotion-$pkgver.tar.gz"
+
+_builddir="$srcdir"/emotion-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="171bbc41a5e5d202d0dc57c34e318c14 emotion-1.7.9.tar.gz"
+sha256sums="ff72204490e740adaa7980bad1a060dae8113c308c6083e5bcee380a11dad1f4 emotion-1.7.9.tar.gz"
+sha512sums="8da35d09f07560305ea43a06d1101f25e8a764d88e8e14b19d2f2410a8ea94a51e1058cf122466d0d5e17d8057e9180f0a898082a6d637de59491741b73bea02 emotion-1.7.9.tar.gz"