aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/foremost/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/foremost/APKBUILD')
-rw-r--r--unmaintained/foremost/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/unmaintained/foremost/APKBUILD b/unmaintained/foremost/APKBUILD
new file mode 100644
index 0000000000..4fbff540a1
--- /dev/null
+++ b/unmaintained/foremost/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Jesse Young <jlyo@jlyo.org>
+# Maintainer: Jesse Young <jlyo@jlyo.org>
+
+pkgname=foremost
+pkgver=1.5.7
+pkgrel=1
+pkgdesc="A console program to recover files based on their headers, footers, and internal data structures"
+url="http://foremost.sourceforge.net/"
+arch="all"
+license="custom"
+depends_dev=""
+depends=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://foremost.sourceforge.net/pkg/${pkgname}-${pkgver}.tar.gz \
+ ${pkgname}-makefile.patch"
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make
+}
+
+package () {
+ cd "$_builddir"
+ for f in etc usr/bin usr/share/man/man8 usr/share/licenses/foremost; do
+ install -dm755 "${pkgdir}/${f}"
+ done
+ make DESTDIR="$pkgdir" install
+ ./foremost -V > "${pkgdir}/usr/share/licenses/${pkgname}/COPYRIGHT"
+}
+
+md5sums="860119c49665c2a3fb2b0b1d3dbad02a foremost-1.5.7.tar.gz
+e78b7e14ef18a7941bb558af00f3b294 foremost-makefile.patch"
+sha256sums="502054ef212e3d90b292e99c7f7ac91f89f024720cd5a7e7680c3d1901ef5f34 foremost-1.5.7.tar.gz
+80592050c42571b7254a7e166d56b9761a6c72050406dc8adf35aff934bd242a foremost-makefile.patch"
+sha512sums="8827c29d52496783be26374f3943eb26a154d842f34e50fb489f87b3a5045bf85f1e44d7d8d8b12b2355ba3fe4b06a0db979cc22c0f431593c5976001eb931ab foremost-1.5.7.tar.gz
+22c28169e19c3fedb1f9ad470a6218ce63091f813257a222bda66d2ae04933e2694bc17ba4635b75db94f5375485ac0d5c1583c175b4d1674a9ff58c29967caa foremost-makefile.patch"