aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/gnome-control-center/link-gmodule.patch
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/gnome-control-center/link-gmodule.patch')
-rw-r--r--unmaintained/gnome-control-center/link-gmodule.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/unmaintained/gnome-control-center/link-gmodule.patch b/unmaintained/gnome-control-center/link-gmodule.patch
new file mode 100644
index 0000000000..9bf14ec961
--- /dev/null
+++ b/unmaintained/gnome-control-center/link-gmodule.patch
@@ -0,0 +1,26 @@
+diff --git a/capplets/appearance/Makefile.in b/capplets/appearance/Makefile.in
+index 4b8df30..9c62c4f 100644
+--- a/capplets/appearance/Makefile.in
++++ b/capplets/appearance/Makefile.in
+@@ -386,7 +386,7 @@ gnome_appearance_properties_LDADD = \
+ $(top_builddir)/capplets/common/libcommon.la \
+ $(GNOMECC_CAPPLETS_LIBS) \
+ $(FONT_CAPPLET_LIBS) \
+- $(METACITY_LIBS)
++ $(METACITY_LIBS) -lgmodule-2.0
+
+ gnome_appearance_properties_LDFLAGS = -export-dynamic
+ gtkbuilderdir = $(pkgdatadir)/ui
+diff --git a/capplets/common/Makefile.in b/capplets/common/Makefile.in
+index 00e594a..5f1849a 100644
+--- a/capplets/common/Makefile.in
++++ b/capplets/common/Makefile.in
+@@ -365,7 +365,7 @@ gnome_theme_test_SOURCES = \
+
+ gnome_theme_test_LDADD = \
+ libcommon.la \
+- $(GNOMECC_CAPPLETS_LIBS)
++ $(GNOMECC_CAPPLETS_LIBS) -lgmodule-2.0
+
+ all: all-am
+