aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/ideviceinstaller/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/ideviceinstaller/APKBUILD')
-rw-r--r--unmaintained/ideviceinstaller/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/unmaintained/ideviceinstaller/APKBUILD b/unmaintained/ideviceinstaller/APKBUILD
new file mode 100644
index 0000000000..48a81cf32f
--- /dev/null
+++ b/unmaintained/ideviceinstaller/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=ideviceinstaller
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="Manage Applications of an iPhone or iPod Touch"
+url="http://www.libimobiledevice.org/"
+arch="all"
+license="LGPL2.1"
+depends=""
+depends_dev=""
+makedepends="$depends_dev libimobiledevice-dev libzip-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://www.libimobiledevice.org/downloads/$pkgname-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ sed -i -e 's:-Werror -g::' configure || return 1
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="20bd74111c1e8bf7ce393f8f0919263c ideviceinstaller-1.1.0.tar.bz2"
+sha256sums="0821b8d3ca6153d9bf82ceba2706f7bd0e3f07b90a138d79c2448e42362e2f53 ideviceinstaller-1.1.0.tar.bz2"
+sha512sums="8bf5dc30b8fa2f0c171ec3705db8d8d143d2520b2875fc05d9d325bd4f1ffdf29230557e57f3e824654ab3bb71bbaf9019aa573d4b1cce29a9c75bf15024d623 ideviceinstaller-1.1.0.tar.bz2"