aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/mod_auth_cas/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/mod_auth_cas/APKBUILD')
-rw-r--r--unmaintained/mod_auth_cas/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/unmaintained/mod_auth_cas/APKBUILD b/unmaintained/mod_auth_cas/APKBUILD
new file mode 100644
index 0000000000..0df9c31264
--- /dev/null
+++ b/unmaintained/mod_auth_cas/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=mod_auth_cas
+pkgver=1.2
+pkgrel=0
+pkgdesc="An Apache httpd module for integrating with Apereo (JASIG) CAS Server project"
+url="https://www.apereo.org/projects/cas"
+arch="all"
+license="Apache-2.0"
+makedepends="apache2-dev curl-dev pcre-dev"
+source="
+ mod_auth_cas-$pkgver.tar.gz::https://github.com/Jasig/mod_auth_cas/archive/v$pkgver.tar.gz
+ remove-error.h.patch
+ "
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="e1ca75493ba6132c2c3d4d888bc3f25ad9674441d1f89fada64db515f4faf899ce655c1c09b0f6a4cd6169d6ac7d16901e062aa7cacd3b95ecfcd5d8ea030b6d mod_auth_cas-1.2.tar.gz
+7e0d9dd6022e8a6243ca8650e189d3ca2a35301d9966cb7e3a31b99348d6b2cd3c3f75910fd8ea891c9f5f0ba89d1a047223b72ebcd9844121228e5909868679 remove-error.h.patch"