aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/nicotine-plus/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/nicotine-plus/APKBUILD')
-rw-r--r--unmaintained/nicotine-plus/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/unmaintained/nicotine-plus/APKBUILD b/unmaintained/nicotine-plus/APKBUILD
new file mode 100644
index 0000000000..3b1ee65ea5
--- /dev/null
+++ b/unmaintained/nicotine-plus/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: dai9ah <dai9ah@protonmail.com>
+# Maintainer: dai9ah <dai9ah@protonmail.com>
+pkgname=nicotine-plus
+pkgver=1.4.1
+pkgrel=0
+pkgdesc="Graphical client for the SoulSeek peer-to-peer system"
+url="http://nicotine-plus.org"
+arch="noarch"
+license="GPL-3.0-or-later"
+depends="librsvg py-gtk py-mutagen"
+subpackages="$pkgname-doc $pkgname-lang"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Nicotine-Plus/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="894dfb318b205b6be21face0308f183da15772f329158c6a9a8a816dfdf231ad89245188acad5538821b2a778c8a8a6201ce8548cc58550c4eb6c0763db9d66a nicotine-plus-1.4.1.tar.gz"