aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/otf-tex-gyre/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/otf-tex-gyre/APKBUILD')
-rw-r--r--unmaintained/otf-tex-gyre/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/unmaintained/otf-tex-gyre/APKBUILD b/unmaintained/otf-tex-gyre/APKBUILD
new file mode 100644
index 0000000000..bc64038ea6
--- /dev/null
+++ b/unmaintained/otf-tex-gyre/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=otf-tex-gyre
+pkgver=2.005
+pkgrel=0
+pkgdesc="The TeX Gyre (TG) Collection of Fonts."
+url="http://www.gust.org.pl/projects/e-foundry/tex-gyre/"
+arch="noarch"
+license="GFL"
+depends="fontconfig"
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages=""
+# added fontconfig configuration from:
+# https://github.com/bohoomil/fontconfig-ultimate/tree/master/fontconfig_patches/fonts-settings
+source="http://www.gust.org.pl/projects/e-foundry/tex-gyre/whole/tg-${pkgver}otf.zip
+ 45-tex-gyre.conf
+ 90-non-tt-tex-gyre.conf"
+
+_builddir="$srcdir"
+
+build() {
+ cd "$_builddir"
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/share/fonts/$pkgname \
+ "$pkgdir"/etc/fonts/conf.avail \
+ "$pkgdir"/etc/fonts/conf.d
+ install -m644 *.otf \
+ "${pkgdir}"/usr/share/fonts/"${pkgname}"
+ for j in "$srcdir"/*.conf; do
+ install -m644 "$j" \
+ "$pkgdir"/etc/fonts/conf.avail/ || return 1
+ cd "$pkgdir"/etc/fonts/conf.d
+ ln -sf /etc/fonts/conf.avail/${j##*/}
+ done
+}
+md5sums="3774af603b5a13d374bf4668967bff57 tg-2.005otf.zip
+b4ac89e4df3907a6cd9b91642ff9c8a5 45-tex-gyre.conf
+1717b23af91c9ad79618bf0174acd73a 90-non-tt-tex-gyre.conf"
+sha256sums="6158bdb106e5b017743cb6e9ddb6ad4c7153e82fafadd6eb5d62c9f3064df04e tg-2.005otf.zip
+e0a49b011eac2e51dbb844706825c3b84f4c9a0a1640d2d6f8b462dd29bb2fe7 45-tex-gyre.conf
+63ac80d34f712bc6bb400875793e26add4905b91a5a65bc0bacf71ea886e20b3 90-non-tt-tex-gyre.conf"
+sha512sums="881886115604a7ec2634f621693177278bf3f6842dd42f64460e3afd26f302c2f8847e03b7bd83b354ae0366dcdfa057f16b1cbf64e8c5172d27d2bda7b98db9 tg-2.005otf.zip
+63c356e4d3ed0986c03ffdb1e37b85adc4de5e9ee5e0a5431157bd52798fa7952f1230f04e401e2e010e2531269aecff0bb6c0efbe4c573cb02393920a3b986e 45-tex-gyre.conf
+0e118ea843ca40bba2461790e4dca61cf936dadb5be9efbf05add974cd7531d49ed66b900d8ab85312566a0efed79b7eb8b551b95d0e2bf9c441bb13338ecaaa 90-non-tt-tex-gyre.conf"