aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/perl-config-tiny/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/perl-config-tiny/APKBUILD')
-rw-r--r--unmaintained/perl-config-tiny/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/unmaintained/perl-config-tiny/APKBUILD b/unmaintained/perl-config-tiny/APKBUILD
new file mode 100644
index 0000000000..e514e7d353
--- /dev/null
+++ b/unmaintained/perl-config-tiny/APKBUILD
@@ -0,0 +1,44 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=perl-config-tiny
+_pkgreal=Config-Tiny
+pkgver=2.23
+pkgrel=0
+pkgdesc="Perl module for Config-Tiny"
+url="http://search.cpan.org/dist/Config-Tiny/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=""
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/R/RS/RSAVAGE/$_pkgreal-$pkgver.tgz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ if [ -e Build.PL ]; then
+ perl Build.PL installdirs=vendor || return 1
+ else
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ fi
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="6c3bc610c4bc587e1441e651e01584ce Config-Tiny-2.23.tgz"
+sha256sums="9a8a66e3ed420cbc6585c43abeff788368309a46355cf69a64c2a47e1911e50c Config-Tiny-2.23.tgz"
+sha512sums="c5c77aa18a387f181ba9bb2df8859c328073521e14163fe04fd7a104928bd68cf654eab88d24bd23e556e6ecc139dfed716fb7b8119e98cd2ab6f6915c976f01 Config-Tiny-2.23.tgz"