aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/perl-io-async-ssl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/perl-io-async-ssl/APKBUILD')
-rw-r--r--unmaintained/perl-io-async-ssl/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/unmaintained/perl-io-async-ssl/APKBUILD b/unmaintained/perl-io-async-ssl/APKBUILD
new file mode 100644
index 0000000000..8ca3af3113
--- /dev/null
+++ b/unmaintained/perl-io-async-ssl/APKBUILD
@@ -0,0 +1,40 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+pkgname=perl-io-async-ssl
+_pkgreal=IO-Async-SSL
+pkgver=0.14
+pkgrel=0
+pkgdesc="Use SSL/TLS with L<IO::Async>"
+url="http://search.cpan.org/dist/IO-Async-SSL/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-io-socket-ssl perl-io-async"
+cpanmakedepends="perl-test-pod perl-test-identity"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/P/PE/PEVANS/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ perl Build.PL installdirs=vendor || return 1
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ ./Build && ./Build test
+}
+
+package() {
+ cd "$_builddir"
+ ./Build install destdir="$pkgdir" || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="c7f50698d3dc9e23a6dafe44244f5c70 IO-Async-SSL-0.14.tar.gz"
+sha256sums="81bea9f52cf468bda85b70460fc5b351be2cf04cfaa97e363ddb1cbb3cef3d62 IO-Async-SSL-0.14.tar.gz"
+sha512sums="d6f175b596fc0781599ffb487ade857279a3d159a974ab6a82d134841d6ef219e353b10004e7cef8da3ff46159fcae22ad261eac84cc1e6973181452f0fe6b51 IO-Async-SSL-0.14.tar.gz"