aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/physfs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/physfs/APKBUILD')
-rw-r--r--unmaintained/physfs/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/unmaintained/physfs/APKBUILD b/unmaintained/physfs/APKBUILD
new file mode 100644
index 0000000000..5bca842223
--- /dev/null
+++ b/unmaintained/physfs/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor:
+# Maintainer:
+pkgname=physfs
+pkgver=2.0.3
+pkgrel=0
+pkgdesc="PhysicsFS is a library to provide abstract access to various archives"
+url="http://icculus.org/physfs/"
+arch="all"
+license="custom zlib"
+depends=""
+depends_dev="zlib-dev"
+makedepends="$depends_dev cmake doxygen"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://icculus.org/physfs/downloads/physfs-$pkgver.tar.bz2
+ silence-gcc.patch"
+
+_builddir="$srcdir"/physfs-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir" && mkdir bld && cd bld && \
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ../ && make || return 1
+}
+
+package() {
+ cd "$_builddir" && \
+ install -d "$pkgdir"/usr/share/licenses/"$pkgname" && \
+ install -m644 LICENSE.txt "$pkgdir"/usr/share/licenses/"$pkgname"/ && \
+ cd bld && make install DESTDIR="$pkgdir" || return 1
+}
+
+md5sums="c2c727a8a8deb623b521b52d0080f613 physfs-2.0.3.tar.bz2
+a2a01b5f5ddf9f6a37f8a8289edd69cc silence-gcc.patch"
+sha256sums="ca862097c0fb451f2cacd286194d071289342c107b6fe69079c079883ff66b69 physfs-2.0.3.tar.bz2
+9eaeedabe7df2b80ab8c4ae4114d9ecbb9ab2125c14e5ca56b24d21387e06178 silence-gcc.patch"
+sha512sums="47eff0c81b8dc3bb526766b0a8ad2437d2951867880116d6e6e8f2ec1490e263541fb741867fed6517cc3fa8a9c5651b36e3e02a499f19cfdc5c7261c9707e80 physfs-2.0.3.tar.bz2
+4e18558d23982d71aac5f6509bd771f65dd52d5e75d969d0ac0561e34a58cd183973157b5fd7f713ba4c32e3b30c5f5abc97de571cf301aad98538cc016154b4 silence-gcc.patch"