aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/pptpclient/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/pptpclient/APKBUILD')
-rw-r--r--unmaintained/pptpclient/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/unmaintained/pptpclient/APKBUILD b/unmaintained/pptpclient/APKBUILD
new file mode 100644
index 0000000000..757fff26b8
--- /dev/null
+++ b/unmaintained/pptpclient/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=pptpclient
+pkgver=1.7.2
+pkgrel=1
+pkgdesc="Client for the proprietary Microsoft Point-to-Point Tunneling Protocol, PPTP."
+url="http://pptpclient.sourceforge.net/"
+arch="all"
+license="GPL"
+depends="ppp iproute2"
+makedepends="perl"
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/sourceforge/$pkgname/pptp-$pkgver.tar.gz
+ pptpclient-uclibc.patch"
+
+prepare() {
+ cd "$srcdir"/pptp-$pkgver
+ patch -p1 -i "$srcdir"/pptpclient-uclibc.patch || return 1
+ sed -i '/CFLAGS/d' Makefile
+ sed -i 's|\/bin\/ip|\/usr\/sbin\/ip|g' routing.c
+}
+
+build() {
+ cd "$srcdir"/pptp-$pkgver
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/pptp-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+md5sums="4c3d19286a37459a632c7128c92a9857 pptp-1.7.2.tar.gz
+34b643e4e4224e723f6a768018b46015 pptpclient-uclibc.patch"