aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/py-beautifulsoup/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/py-beautifulsoup/APKBUILD')
-rw-r--r--unmaintained/py-beautifulsoup/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/unmaintained/py-beautifulsoup/APKBUILD b/unmaintained/py-beautifulsoup/APKBUILD
new file mode 100644
index 0000000000..5cb0d4068d
--- /dev/null
+++ b/unmaintained/py-beautifulsoup/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer:
+pkgname=py-beautifulsoup
+_pkgname=BeautifulSoup
+pkgver=3.2.1
+pkgrel=0
+pkgdesc="A Python HTML/XML parser designed for quick turnaround projects like screen-scraping"
+url="http://www.crummy.com/software/BeautifulSoup/index.html"
+arch="noarch"
+license="BSD"
+depends=""
+depends_dev="python-dev"
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="http://www.crummy.com/software/BeautifulSoup/download/3.x/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="5ad1a8550a19bfc945baac23eb8293ed BeautifulSoup-3.2.1.tar.gz"