aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/ruby-unicorn
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/ruby-unicorn')
-rw-r--r--unmaintained/ruby-unicorn/APKBUILD65
-rw-r--r--unmaintained/ruby-unicorn/redmine.conf.rb.sample103
-rw-r--r--unmaintained/ruby-unicorn/unicorn.confd4
-rw-r--r--unmaintained/ruby-unicorn/unicorn.initd44
4 files changed, 216 insertions, 0 deletions
diff --git a/unmaintained/ruby-unicorn/APKBUILD b/unmaintained/ruby-unicorn/APKBUILD
new file mode 100644
index 0000000000..6068cb35b3
--- /dev/null
+++ b/unmaintained/ruby-unicorn/APKBUILD
@@ -0,0 +1,65 @@
+# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
+_gemname=unicorn
+pkgname=ruby-unicorn
+pkgver=4.8.3
+pkgrel=2
+pkgdesc="Unicorn is an HTTP server for Rack applications"
+url="http://unicorn.bogomips.org"
+arch="all"
+license="MIT"
+depends="ruby ruby-kgio ruby-rack ruby-raindrops"
+depends_dev="ruby-dev"
+makedepends="$depends_dev ruby"
+install=""
+subpackages=""
+source="http://gems.rubyforge.org/gems/$_gemname-$pkgver.gem
+ redmine.conf.rb.sample
+ unicorn.initd
+ unicorn.confd"
+
+_builddir="$srcdir"/$_realname-$pkgver
+build() {
+ return 0
+}
+
+package() {
+ local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+ local _geminstdir=$_gemdir/gems/$_gemname-$pkgver
+ mkdir -p "$pkgdir" || return 1
+
+ gem install --local --install-dir "$pkgdir"/$_gemdir \
+ --ignore-dependencies --verbose --no-rdoc --no-ri \
+ "$srcdir"/$_gemname-$pkgver.gem || return 1
+ rm -rf "$pkgdir"/$_gemdir/cache \
+ "$pkgdir"/$_geminstdir/ext \
+ "$pkgdir"/$_geminstdir/.require_paths
+
+ cd "$pkgdir"
+ for i in usr/lib/ruby/gems/*/bin/*; do
+ if [ -e "$i" ]; then
+ mkdir -p "$pkgdir"/usr/bin
+ ln -s /$i "$pkgdir"/usr/bin/
+ fi
+ done
+
+ install -Dm644 "$srcdir"/$_gemname.confd \
+ "$pkgdir"/etc/conf.d/$_gemname
+ install -D -m755 "$srcdir"/$_gemname.initd \
+ "$pkgdir"/etc/init.d/$_gemname
+ # install sample redmine config
+ install -D -m644 "$srcdir"/redmine.conf.rb.sample \
+ "$pkgdir"/etc/unicorn/redmine.conf.rb.sample
+}
+
+md5sums="d1f58658c7ad4e46c4f319cc715fb710 unicorn-4.8.3.gem
+416e6d6c3e5f9f191d1e8c3975b0d4f5 redmine.conf.rb.sample
+f32a54abc3df5273620bd493f314c3ee unicorn.initd
+0745d4e1605ff961c83773613c68347d unicorn.confd"
+sha256sums="44b74e46fc8cd67510ecc7fac31d4c8503955066781542b36f1d8a3ee316efce unicorn-4.8.3.gem
+87a565f79a3f4b0544880af67c66e28fa0afdca9576191e725853da1159ec1f1 redmine.conf.rb.sample
+41cc2f5235d15e2bf1676a35464013630aa0518773e1de21519fc1eceda54eee unicorn.initd
+8b6c5aff19eb8234192f8df79f5c8c7a2325f8f26a90af97271bf126269dc93c unicorn.confd"
+sha512sums="6c8a3c9331d380ebe6e9765a873a4ec37e91dc5e743af5f3d6814ffc19dabb64945994463bb64b7dc43e9a78160fa6f1e5b6c9e1f41b3a54089793f801c44e73 unicorn-4.8.3.gem
+11abdc40c406e88c71feeb1bd6282534552f782398b694907e6afb266361e30091f4e9645e3ae9cc14bae68a4909cb087bbf0f6c13c3e26b41518565e942492d redmine.conf.rb.sample
+eddf9b47c56c5962e7fe832f06ceecf3c4320ac00b39f8b06846bf542d5aaf9c78cded5a6e33675197593463d0192d4d61a7e14dea938b7227458c8c57d15a28 unicorn.initd
+40931b0f41f8f19ed2bfee726c6abdf40e9ca03940ca6fa4db0c468b59409b99506dbad47316dec528ae7173b6bd3856ba80be1f45fa3995ed18efefed1c4ce1 unicorn.confd"
diff --git a/unmaintained/ruby-unicorn/redmine.conf.rb.sample b/unmaintained/ruby-unicorn/redmine.conf.rb.sample
new file mode 100644
index 0000000000..6b47bd1356
--- /dev/null
+++ b/unmaintained/ruby-unicorn/redmine.conf.rb.sample
@@ -0,0 +1,103 @@
+# Sample verbose configuration file for Unicorn (not Rack)
+#
+# This configuration file documents many features of Unicorn
+# that may not be needed for some applications. See
+# http://unicorn.bogomips.org/examples/unicorn.conf.minimal.rb
+# for a much simpler configuration file.
+#
+# See http://unicorn.bogomips.org/Unicorn/Configurator.html for complete
+# documentation.
+
+# Use at least one worker per core if you're on a dedicated server,
+# more will usually help for _short_ waits on databases/caches.
+worker_processes 2
+
+# Since Unicorn is never exposed to outside clients, it does not need to
+# run on the standard HTTP port (80), there is no reason to start Unicorn
+# as root unless it's from system init scripts.
+# If running the master process as root and the workers as an unprivileged
+# user, do this to switch euid/egid in the workers (also chowns logs):
+# user "unprivileged_user", "unprivileged_group"
+user "redmine", "redmine"
+
+# Help ensure your application will always spawn in the symlinked
+# "current" directory that Capistrano sets up.
+working_directory "/usr/share/webapps/redmine" # available in 0.94.0+
+
+# listen on both a Unix domain socket and a TCP port,
+# we use a shorter backlog for quicker failover when busy
+listen "/var/run/unicorn.sock", :backlog => 64
+listen 8080, :tcp_nopush => true
+
+# nuke workers after 30 seconds instead of 60 seconds (the default)
+#timeout 30
+
+# feel free to point this anywhere accessible on the filesystem
+pid "/var/run/unicorn.pid"
+
+# By default, the Unicorn logger will write to stderr.
+# Additionally, ome applications/frameworks log to stderr or stdout,
+# so prevent them from going to /dev/null when daemonized here:
+stderr_path "/var/log/redmine/unicorn.log"
+stdout_path "/var/log/redmine/unicorn.log"
+
+# combine Ruby 2.0.0dev or REE with "preload_app true" for memory savings
+# http://rubyenterpriseedition.com/faq.html#adapt_apps_for_cow
+preload_app true
+GC.respond_to?(:copy_on_write_friendly=) and
+ GC.copy_on_write_friendly = true
+
+# Enable this flag to have unicorn test client connections by writing the
+# beginning of the HTTP headers before calling the application. This
+# prevents calling the application for connections that have disconnected
+# while queued. This is only guaranteed to detect clients on the same
+# host unicorn runs on, and unlikely to detect disconnects even on a
+# fast LAN.
+#check_client_connection false
+
+before_fork do |server, worker|
+ # the following is highly recomended for Rails + "preload_app true"
+ # as there's no need for the master process to hold a connection
+ defined?(ActiveRecord::Base) and
+ ActiveRecord::Base.connection.disconnect!
+
+ # The following is only recommended for memory/DB-constrained
+ # installations. It is not needed if your system can house
+ # twice as many worker_processes as you have configured.
+ #
+ # # This allows a new master process to incrementally
+ # # phase out the old master process with SIGTTOU to avoid a
+ # # thundering herd (especially in the "preload_app false" case)
+ # # when doing a transparent upgrade. The last worker spawned
+ # # will then kill off the old master process with a SIGQUIT.
+ # old_pid = "#{server.config[:pid]}.oldbin"
+ # if old_pid != server.pid
+ # begin
+ # sig = (worker.nr + 1) >= server.worker_processes ? :QUIT : :TTOU
+ # Process.kill(sig, File.read(old_pid).to_i)
+ # rescue Errno::ENOENT, Errno::ESRCH
+ # end
+ # end
+ #
+ # Throttle the master from forking too quickly by sleeping. Due
+ # to the implementation of standard Unix signal handlers, this
+ # helps (but does not completely) prevent identical, repeated signals
+ # from being lost when the receiving process is busy.
+ # sleep 1
+end
+
+after_fork do |server, worker|
+ # per-process listener ports for debugging/admin/migrations
+ # addr = "127.0.0.1:#{9293 + worker.nr}"
+ # server.listen(addr, :tries => -1, :delay => 5, :tcp_nopush => true)
+
+ # the following is *required* for Rails + "preload_app true",
+ defined?(ActiveRecord::Base) and
+ ActiveRecord::Base.establish_connection
+
+ # if preload_app is true, then you may also want to check and
+ # restart any other shared sockets/descriptors such as Memcached,
+ # and Redis. TokyoCabinet file handles are safe to reuse
+ # between any number of forked children (assuming your kernel
+ # correctly implements pread()/pwrite() system calls)
+end
diff --git a/unmaintained/ruby-unicorn/unicorn.confd b/unmaintained/ruby-unicorn/unicorn.confd
new file mode 100644
index 0000000000..28e3df1a21
--- /dev/null
+++ b/unmaintained/ruby-unicorn/unicorn.confd
@@ -0,0 +1,4 @@
+# unicorn configuration file
+CONF=""
+# app enviorment. ie developement,production
+ENV="production"
diff --git a/unmaintained/ruby-unicorn/unicorn.initd b/unmaintained/ruby-unicorn/unicorn.initd
new file mode 100644
index 0000000000..daa4fa47a5
--- /dev/null
+++ b/unmaintained/ruby-unicorn/unicorn.initd
@@ -0,0 +1,44 @@
+#!/sbin/openrc-run
+
+gem_path=$(gem env gemdir)
+name="unicorn_rails"
+start_script="$gem_path/bin/$name"
+
+depend() {
+ use logger dns
+ need net
+ after firewall
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting unicorn"
+ start-stop-daemon --start --quiet \
+ $start_script -- \
+ -D -E $ENV -c $CONF
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping unicorn"
+ start-stop-daemon --stop \
+ --name $name
+ eend $?
+ sleep 1
+}
+
+
+reload() {
+ ebegin "Reload unicorn"
+ start-stop-daemon --signal USR2 \
+ --name $name
+ eend $?
+}
+
+checkconfig() {
+ if [ -z "$CONF" ]; then
+ eerror "No configuration file set in confd!"
+ return 1
+ fi
+}