aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/speech-dispatcher/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/speech-dispatcher/APKBUILD')
-rw-r--r--unmaintained/speech-dispatcher/APKBUILD59
1 files changed, 59 insertions, 0 deletions
diff --git a/unmaintained/speech-dispatcher/APKBUILD b/unmaintained/speech-dispatcher/APKBUILD
new file mode 100644
index 0000000000..3097c37a73
--- /dev/null
+++ b/unmaintained/speech-dispatcher/APKBUILD
@@ -0,0 +1,59 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=speech-dispatcher
+pkgver=0.8.2
+pkgrel=0
+pkgdesc="High-level device independent layer for speech synthesis interface"
+url="http://www.freebsoft.org/speechd"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev="glib-dev dotconf-dev"
+makedepends="$depends_dev intltool libtool"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="http://devel.freebsoft.org/pub/projects/speechd/speech-dispatcher-$pkgver.tar.gz
+ 0001-Make-some-includes-consistent-with-POSIX.patch
+ 0001-Provide-fallback-for-systems-without-TEMP_FAILURE_RE.patch"
+
+_builddir="$srcdir"/speech-dispatcher-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --without-flite \
+ --without-pulse \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="6beee9a1e4792508bf6d638c750229cc speech-dispatcher-0.8.2.tar.gz
+a5982a0f81d8463923f286f15dcb141a 0001-Make-some-includes-consistent-with-POSIX.patch
+f8f4bbfcd064a1fb35888f85d34e6984 0001-Provide-fallback-for-systems-without-TEMP_FAILURE_RE.patch"
+sha256sums="475c109e70670a02aa8bece9b6358d977f16d4ee6c9fc22cfa043cb2d9ddb55f speech-dispatcher-0.8.2.tar.gz
+6a08763dd8d42283fb1cd0341ace5c948a3662e522137098a0043cb59308ebbb 0001-Make-some-includes-consistent-with-POSIX.patch
+32d72cb4ba7a72cb7714e8f7226b34e21f3e57765a13c39cece38e966857e0c5 0001-Provide-fallback-for-systems-without-TEMP_FAILURE_RE.patch"
+sha512sums="2fd2656055cb266fa0cbec87f025c2bca0ab9bc114c0f894f4cfd9f38d480fe1dab27969a17162de24f278269f8cb24a8b4567e114a27271fefba41615c35977 speech-dispatcher-0.8.2.tar.gz
+76ad3f2e56a2e3ff85880da337dfae73b9c247b69a64584fbc045dc5055ef9f24a9f7788dae65b91d084b5a0f5c04336d40e6eaa7420abae58bc6d19f3121a9e 0001-Make-some-includes-consistent-with-POSIX.patch
+ee5527670346c14c6453ac7aee320dca8360f963599bd95123ef5828d09d7a5c2907dddfd81b8477c198dcc8b1ca98c01fd9c73cd1b74d74083766904c7ea424 0001-Provide-fallback-for-systems-without-TEMP_FAILURE_RE.patch"