aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/squidguard
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/squidguard')
-rw-r--r--unmaintained/squidguard/APKBUILD53
-rw-r--r--unmaintained/squidguard/blockedsites1
-rw-r--r--unmaintained/squidguard/squidGuard.conf.blocksites13
-rw-r--r--unmaintained/squidguard/squidGuard.conf.minimal7
-rw-r--r--unmaintained/squidguard/squidguard-1.4-debian-bdb-51.patch24
-rw-r--r--unmaintained/squidguard/squidguard-1.4-gentoo.patch74
-rw-r--r--unmaintained/squidguard/squidguard-1.4-upstream-fixes.patch24
-rw-r--r--unmaintained/squidguard/squidguard-1.4-vsnprintf.patch44
8 files changed, 0 insertions, 240 deletions
diff --git a/unmaintained/squidguard/APKBUILD b/unmaintained/squidguard/APKBUILD
deleted file mode 100644
index df2fdc8bcf..0000000000
--- a/unmaintained/squidguard/APKBUILD
+++ /dev/null
@@ -1,53 +0,0 @@
-# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
-pkgname=squidguard
-_realname=squidGuard
-pkgver=1.4
-pkgrel=6
-pkgdesc="Squid URL redirector"
-url="http://www.squidguard.org"
-arch="all"
-license="GPL"
-depends=
-makedepends="flex bison db-dev"
-install=
-pkgusers="squid"
-pkggroups="squid"
-subpackages=""
-source="http://www.squidguard.org/Downloads/$_realname-$pkgver.tar.gz
- squidguard-1.4-gentoo.patch
- squidguard-1.4-upstream-fixes.patch
- squidguard-1.4-vsnprintf.patch
- squidguard-1.4-debian-bdb-51.patch"
-
-_builddir="$srcdir"/$_realname-$pkgver
-
-prepare() {
- cd "$_builddir"
- patch -p1 < ../../squidguard-1.4-gentoo.patch
- patch -p1 < ../../squidguard-1.4-upstream-fixes.patch
- patch -p1 < ../../squidguard-1.4-vsnprintf.patch
- patch -p1 < ../../squidguard-1.4-debian-bdb-51.patch
-}
-
-build() {
- cd "$_builddir"
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --with-sg-config=/etc/squidGuard/squidGuard.conf \
- --with-sg-logdir=/var/log/squidGuard
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make INSTDIR="$pkgdir" install
- install -D -m644 ../../squidGuard.conf.blocksites $pkgdir/etc/squidGuard/squidGuard.conf
- install -D -m644 ../../blockedsites $pkgdir/etc/squidGuard/blockedsites
- mkdir -p "$pkgdir"/var/log/squidGuard && chown squid.squid "$pkgdir"/var/log/squidGuard
-}
-
-md5sums="de834150998c1386c30feae196f16b06 squidGuard-1.4.tar.gz
-ba58e934fe2f75fcb5dfbe054e045449 squidguard-1.4-gentoo.patch
-4b512e930dede70ddf36d4f7c75a598f squidguard-1.4-upstream-fixes.patch
-8878c72f27e45dab99e5d0197d50caec squidguard-1.4-vsnprintf.patch
-ea2deca296c41107bc981d1a2a093846 squidguard-1.4-debian-bdb-51.patch"
diff --git a/unmaintained/squidguard/blockedsites b/unmaintained/squidguard/blockedsites
deleted file mode 100644
index 46279a47ee..0000000000
--- a/unmaintained/squidguard/blockedsites
+++ /dev/null
@@ -1 +0,0 @@
-sex.com
diff --git a/unmaintained/squidguard/squidGuard.conf.blocksites b/unmaintained/squidguard/squidGuard.conf.blocksites
deleted file mode 100644
index eaa8cdeef0..0000000000
--- a/unmaintained/squidguard/squidGuard.conf.blocksites
+++ /dev/null
@@ -1,13 +0,0 @@
-logdir /var/log/squidGuard
-dbhome /etc/squidGuard/db
-
-dest blockedsites {
- domainlist blockedsites
-}
-
-acl {
- default {
- pass !blockedsites all
- redirect http://www.sample.com/empty.png
- }
-}
diff --git a/unmaintained/squidguard/squidGuard.conf.minimal b/unmaintained/squidguard/squidGuard.conf.minimal
deleted file mode 100644
index 3b0ebf55c7..0000000000
--- a/unmaintained/squidguard/squidGuard.conf.minimal
+++ /dev/null
@@ -1,7 +0,0 @@
-logdir /var/log/squidGuard
-
-acl {
- default {
- pass all
- }
-}
diff --git a/unmaintained/squidguard/squidguard-1.4-debian-bdb-51.patch b/unmaintained/squidguard/squidguard-1.4-debian-bdb-51.patch
deleted file mode 100644
index fc12c14b65..0000000000
--- a/unmaintained/squidguard/squidguard-1.4-debian-bdb-51.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Package: squidguard
-Subject: make it useable with Berkeley DB version 5.x
-Author: Joachim Wiedorn <ad_debian at joonet.de>
-Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=621376
-Forwarded: yes
-Last-Update: 2011-05-31
-
-Since the end of 2010 the is a new major version of Berkeley DB.
-For use with squidguard it need this patch.
-
----
-
-diff -urN s07/src/sgDb.c s08/src/sgDb.c
---- s07/src/sgDb.c 2008-07-14 20:29:41.000000000 +0200
-+++ s08/src/sgDb.c 2011-05-31 20:06:26.328740739 +0200
-@@ -114,7 +114,7 @@
- }
- }
- #endif
--#if DB_VERSION_MAJOR == 4
-+#if DB_VERSION_MAJOR == 4 || DB_VERSION_MAJOR == 5
- if(globalUpdate || createdb || (dbfile != NULL && stat(dbfile,&st))){
- flag = DB_CREATE;
- if(createdb)
diff --git a/unmaintained/squidguard/squidguard-1.4-gentoo.patch b/unmaintained/squidguard/squidguard-1.4-gentoo.patch
deleted file mode 100644
index 60b5461e9e..0000000000
--- a/unmaintained/squidguard/squidguard-1.4-gentoo.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-diff -Nru squidGuard-1.4.orig/Makefile.in squidGuard-1.4/Makefile.in
---- squidGuard-1.4.orig/Makefile.in 2008-05-17 18:36:44.000000000 +0000
-+++ squidGuard-1.4/Makefile.in 2009-01-10 13:02:14.000000000 +0000
-@@ -43,7 +43,7 @@
- # Dependencies for installing
- #
-
--install: install-build install-conf
-+install: install-build
-
- install-conf:
- @echo Installing configuration file ;
-@@ -85,10 +85,10 @@
-
- install-build:
- @echo Installing squidGuard
-- @if [ ! -d $(bindir) ]; then \
-- $(MKINSTALLDIRS) $(bindir) ; \
-+ @if [ ! -d "$(INSTDIR)"/$(bindir) ]; then \
-+ $(MKINSTALLDIRS) "$(INSTDIR)"/$(bindir) ; \
- fi ; \
-- cp src/squidGuard $(bindir) || exit 1 ; \
-+ cp src/squidGuard "$(INSTDIR)"/$(bindir) || exit 1 ; \
- echo Done. ;
-
- clean::
-diff -Nru squidGuard-1.4.orig/src/Makefile.in squidGuard-1.4/src/Makefile.in
---- squidGuard-1.4.orig/src/Makefile.in 2009-01-03 20:05:39.000000000 +0000
-+++ squidGuard-1.4/src/Makefile.in 2009-01-10 13:02:14.000000000 +0000
-@@ -110,6 +110,8 @@
- mv -f y.tab.c y.tab.c.bison
- mv -f y.tab.h y.tab.h.bison
-
-+sg.y sg.l:
-+
- #
- # Dependencies for installing
- #
-@@ -122,8 +124,8 @@
-
- install.bin:: squidGuard
- @echo making $@ in `basename \`pwd\``
-- @$(MKDIR) $(bindir) $(logdir) $(cfgdir)
-- $(INSTALL_PROGRAM) squidGuard $(bindir)/squidGuard
-+ @$(MKDIR) "$(INSTDIR)"/$(bindir) "$(INSTDIR)"/$(logdir) "$(INSTDIR)"/$(cfgdir)
-+ $(INSTALL_PROGRAM) squidGuard "$(INSTDIR)"/$(bindir)/squidGuard
-
- uninstall.bin::
- @echo making $@ in `basename \`pwd\``
-diff -Nru squidGuard-1.4.orig/src/sgDb.c squidGuard-1.4/src/sgDb.c
---- squidGuard-1.4.orig/src/sgDb.c 2008-07-14 18:29:41.000000000 +0000
-+++ squidGuard-1.4/src/sgDb.c 2009-01-10 13:02:14.000000000 +0000
-@@ -103,13 +103,21 @@
- if(createdb)
- flag = flag | DB_TRUNCATE;
- if ((ret =
-+#if DB_VERSION_MAJOR > 4 || (DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1)
-+ Db->dbp->open(Db->dbp, NULL, dbfile, NULL, DB_BTREE, flag, 0664)) != 0) {
-+#else
- Db->dbp->open(Db->dbp, dbfile, NULL, DB_BTREE, flag, 0664)) != 0) {
-+#endif
- (void) Db->dbp->close(Db->dbp, 0);
- sgLogFatalError("Error db_open: %s", strerror(ret));
- }
- } else {
- if ((ret =
-+#if DB_VERSION_MAJOR > 4 || (DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1)
-+ Db->dbp->open(Db->dbp, NULL, dbfile, NULL, DB_BTREE, DB_CREATE, 0664)) != 0) {
-+#else
- Db->dbp->open(Db->dbp, dbfile, NULL, DB_BTREE, DB_CREATE, 0664)) != 0) {
-+#endif
- sgLogFatalError("Error db_open: %s", strerror(ret));
- }
- }
diff --git a/unmaintained/squidguard/squidguard-1.4-upstream-fixes.patch b/unmaintained/squidguard/squidguard-1.4-upstream-fixes.patch
deleted file mode 100644
index 007e6b4c36..0000000000
--- a/unmaintained/squidguard/squidguard-1.4-upstream-fixes.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -Nru squidGuard-1.4.orig/src/sgDiv.c.in squidGuard-1.4/src/sgDiv.c.in
---- squidGuard-1.4.orig/src/sgDiv.c.in 2008-07-14 18:02:43.000000000 +0200
-+++ squidGuard-1.4/src/sgDiv.c.in 2009-11-28 09:33:05.000000000 +0100
-@@ -745,7 +745,7 @@
- p++;
- break;
- case 'u': /* Requested URL */
-- strcat(buf, req->orig);
-+ strncat(buf, req->orig, 2048);
- p++;
- break;
- default:
-diff -Nru squidGuard-1.4.orig/src/sg.h.in squidGuard-1.4/src/sg.h.in
---- squidGuard-1.4.orig/src/sg.h.in 2007-11-16 17:58:32.000000000 +0100
-+++ squidGuard-1.4/src/sg.h.in 2009-11-28 09:33:37.000000000 +0100
-@@ -73,7 +73,7 @@
- #define REQUEST_TYPE_REDIRECT 2
- #define REQUEST_TYPE_PASS 3
-
--#define MAX_BUF 4096
-+#define MAX_BUF 12288
-
- #define DEFAULT_LOGFILE "squidGuard.log"
- #define WARNING_LOGFILE "squidGuard.log"
diff --git a/unmaintained/squidguard/squidguard-1.4-vsnprintf.patch b/unmaintained/squidguard/squidguard-1.4-vsnprintf.patch
deleted file mode 100644
index bf4efec604..0000000000
--- a/unmaintained/squidguard/squidguard-1.4-vsnprintf.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -Nru squidGuard-1.4.orig/configure.in squidGuard-1.4/configure.in
---- squidGuard-1.4.orig/configure.in 2009-04-26 12:28:49.000000000 +0000
-+++ squidGuard-1.4/configure.in 2009-04-26 12:29:35.000000000 +0000
-@@ -421,7 +421,7 @@
- AC_CHECK_FUNCS(regexec, , AC_MSG_ERROR([No regexec library function.]))
- AC_CHECK_FUNCS(strdup, , AC_MSG_ERROR([No strdup library function.]))
- AC_CHECK_FUNCS(strerror, , AC_MSG_ERROR([No strerror library function.]))
--AC_CHECK_FUNCS(vsprintf, , AC_MSG_ERROR([No vsprintf library function.]))
-+AC_CHECK_FUNCS(vsnprintf, , AC_MSG_ERROR([No vsnprintf library function.]))
- AC_CHECK_FUNCS(sigaction)
- AC_CHECK_FUNCS(signal)
-
-diff -Nru squidGuard-1.4.orig/src/sgLog.c squidGuard-1.4/src/sgLog.c
---- squidGuard-1.4.orig/src/sgLog.c 2007-11-16 16:58:32.000000000 +0000
-+++ squidGuard-1.4/src/sgLog.c 2009-04-26 12:31:40.000000000 +0000
-@@ -55,7 +55,7 @@
- char msg[MAX_BUF];
- va_list ap;
- VA_START(ap, format);
-- if(vsprintf(msg, format, ap) > (MAX_BUF - 1))
-+ if(vsnprintf(msg, MAX_BUF, format, ap) > (MAX_BUF - 1))
- fprintf(stderr,"overflow in vsprintf (sgLog): %s",strerror(errno));
- va_end(ap);
- date = niso(0);
-@@ -87,8 +87,8 @@
- char msg[MAX_BUF];
- va_list ap;
- VA_START(ap, format);
-- if(vsprintf(msg, format, ap) > (MAX_BUF - 1))
-- sgLogFatalError("overflow in vsprintf (sgLogError): %s",strerror(errno));
-+ if(vsnprintf(msg, MAX_BUF, format, ap) > (MAX_BUF - 1))
-+ fprintf(stderr,"overflow in vsprintf (sgLogError): %s",strerror(errno));
- va_end(ap);
- sgLog(globalErrorLog,"%s",msg);
- }
-@@ -104,7 +104,7 @@
- char msg[MAX_BUF];
- va_list ap;
- VA_START(ap, format);
-- if(vsprintf(msg, format, ap) > (MAX_BUF - 1))
-+ if(vsnprintf(msg, MAX_BUF, format, ap) > (MAX_BUF - 1))
- return;
- va_end(ap);
- sgLog(globalErrorLog,"%s",msg);