aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/tokyocabinet
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/tokyocabinet')
-rw-r--r--unmaintained/tokyocabinet/APKBUILD60
-rw-r--r--unmaintained/tokyocabinet/dynamic-linking.patch65
-rw-r--r--unmaintained/tokyocabinet/tokyocabinet-manhelp.patch66
3 files changed, 0 insertions, 191 deletions
diff --git a/unmaintained/tokyocabinet/APKBUILD b/unmaintained/tokyocabinet/APKBUILD
deleted file mode 100644
index 1b6c85113d..0000000000
--- a/unmaintained/tokyocabinet/APKBUILD
+++ /dev/null
@@ -1,60 +0,0 @@
-# Contributor: Franz Bettag <franz@bett.ag>
-# Maintainer:
-pkgname=tokyocabinet
-pkgver=1.4.48
-pkgrel=0
-pkgdesc="GDBM and QDBM successor"
-url="http://fallabs.com/tokyocabinet"
-arch="all"
-license="LGPL"
-depends=""
-makedepends="zlib-dev bzip2-dev autoconf"
-install=""
-subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
-source="http://fallabs.com/$pkgname/$pkgname-$pkgver.tar.gz
- tokyocabinet-manhelp.patch
- dynamic-linking.patch
- "
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
- autoconf
-}
-
-build() {
- cd "$_builddir"
- LDFLAGS="$LDFLAGS -lpthread" ./configure \
- --disable-static \
- --prefix /usr \
- --enable-off64 \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" DATADIR=/usr/share/doc install || return 1
-}
-
-libs() {
- pkgdesc="tokyocabinet library"
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/lib "$subpkgdir"/usr/
-}
-
-md5sums="fd03df6965f8f56dd5b8518ca43b4f5e tokyocabinet-1.4.48.tar.gz
-9ea4b840cec6831ba8ddd0696f9ab756 tokyocabinet-manhelp.patch
-e76ef468636f1580f6d7a9baee0d806c dynamic-linking.patch"
-sha256sums="a003f47c39a91e22d76bc4fe68b9b3de0f38851b160bbb1ca07a4f6441de1f90 tokyocabinet-1.4.48.tar.gz
-1c40b06e4f35d85d36b2a6218d945acf8cce6da98dc3ac23233a034e35276bc1 tokyocabinet-manhelp.patch
-edfcb01c20971cc9bbbb3b8d7e2ca8a34613b8e3fb2ffc9db8643665ef9a2246 dynamic-linking.patch"
-sha512sums="b9995c838e713c13f781ab41062caefeb5c613f696dab08039f992f6860413d60a513114b83468cafdf7fc5b5e51ab880226972465d532f873f2a55f615e1440 tokyocabinet-1.4.48.tar.gz
-7fb5cdbf0feeaae42de2a21b3fb41b7ef3b6b353ec12799362044a18b4b3ee59a6c9938d367f6142c00e89e4e8712d5560c027ac71eb3125f95059cca0077157 tokyocabinet-manhelp.patch
-dd0f5c22b88bb64820f53992d17bb924363e40fa27d4a2ea98224faf51272eed85ce8c91dbe6334a5f3e1fececb4b25f09d4d507305a171446d0612f92255271 dynamic-linking.patch"
diff --git a/unmaintained/tokyocabinet/dynamic-linking.patch b/unmaintained/tokyocabinet/dynamic-linking.patch
deleted file mode 100644
index a63d7c21d7..0000000000
--- a/unmaintained/tokyocabinet/dynamic-linking.patch
+++ /dev/null
@@ -1,65 +0,0 @@
---- ./configure.in.orig 2013-06-06 11:10:25.337848805 +0000
-+++ ./configure.in 2013-06-06 11:11:17.151689523 +0000
-@@ -16,7 +16,7 @@
-
- # Targets
- MYHEADERFILES="tcutil.h tchdb.h tcbdb.h tcfdb.h tctdb.h tcadb.h"
--MYLIBRARYFILES="libtokyocabinet.a"
-+MYLIBRARYFILES=""
- MYLIBOBJFILES="tcutil.o tchdb.o tcbdb.o tcfdb.o tctdb.o tcadb.o myconf.o md5.o"
- MYCOMMANDFILES="tcutest tcumttest tcucodec tchtest tchmttest tchmgr"
- MYCOMMANDFILES="$MYCOMMANDFILES tcbtest tcbmttest tcbmgr tcftest tcfmttest tcfmgr"
---- ./configure.in.orig 2009-12-06 21:43:11.000000000 -0500
-+++ ./configure.in 2009-12-17 15:13:58.794592478 -0500
-@@ -31,26 +31,15 @@
- MYPCFILES="tokyocabinet.pc"
-
- # Building flags
--MYCFLAGS="-std=c99 -Wall -fPIC -fsigned-char -O2"
--MYCPPFLAGS="-I. -I\$(INCLUDEDIR) -I$HOME/include -I/usr/local/include"
-+MYCFLAGS="-std=c99 -Wall -fPIC -fsigned-char"
-+MYCPPFLAGS="-I. -I\$(INCLUDEDIR)"
- MYCPPFLAGS="$MYCPPFLAGS -DNDEBUG -D_GNU_SOURCE=1 -D_REENTRANT -D__EXTENSIONS__"
--MYLDFLAGS="-L. -L\$(LIBDIR) -L$HOME/lib -L/usr/local/lib"
-+MYLDFLAGS="-L. -L\$(LIBDIR)"
- MYCMDLDFLAGS=""
- MYRUNPATH="\$(LIBDIR)"
- MYLDLIBPATHENV="LD_LIBRARY_PATH"
- MYPOSTCMD="true"
-
--# Building paths
--PATH="$PATH:$HOME/bin:/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/bin:/sbin"
--PATH="$PATH:/opt/SUNWspro/bin:/usr/ccs/bin:/usr/xpg4/bin:/usr/xpg6/bin:/usr/ucb"
--CPATH="$HOME/include:/usr/local/include:$CPATH"
--LIBRARY_PATH="$HOME/lib:/usr/local/lib:$LIBRARY_PATH"
--LD_LIBRARY_PATH="$HOME/lib:/usr/local/lib:$LD_LIBRARY_PATH"
--PKG_CONFIG_PATH="$HOME/lib/pkgconfig:/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH"
--export PATH CPATH LIBRARY_PATH LD_LIBRARY_PATH PKG_CONFIG_PATH
--
--
--
- #================================================================
- # Options
- #================================================================
---- ./Makefile.in.orig 2009-10-13 08:33:20.000000000 -0400
-+++ ./Makefile.in 2009-12-17 15:15:07.257604314 -0500
-@@ -54,8 +54,8 @@
- LDFLAGS = @MYLDFLAGS@
- CMDLDFLAGS = @MYCMDLDFLAGS@
- LIBS = @LIBS@
--LDENV = LD_RUN_PATH=/lib:/usr/lib:$(LIBDIR):$(HOME)/lib:/usr/local/lib:@MYRUNPATH@:.
--RUNENV = @MYLDLIBPATHENV@=.:/lib:/usr/lib:$(LIBDIR):$(HOME)/lib:/usr/local/lib:@MYRUNPATH@
-+LDENV =
-+RUNENV = @MYLDLIBPATHENV@=.:$(LIBDIR)
- POSTCMD = @MYPOSTCMD@
-
-
---- ./tokyocabinet.pc.in.orig 2008-02-18 02:25:18.000000000 -0500
-+++ ./tokyocabinet.pc.in 2009-12-17 15:15:29.626591709 -0500
-@@ -10,5 +10,5 @@
- Name: Tokyo Cabinet
- Description: a modern implementation of DBM
- Version: @PACKAGE_VERSION@
--Libs: -L${libdir} -ltokyocabinet @LIBS@
-+Libs: -L${libdir} -ltokyocabinet
- Cflags: -I${includedir}
diff --git a/unmaintained/tokyocabinet/tokyocabinet-manhelp.patch b/unmaintained/tokyocabinet/tokyocabinet-manhelp.patch
deleted file mode 100644
index 0e182bdcc0..0000000000
--- a/unmaintained/tokyocabinet/tokyocabinet-manhelp.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-diff -up tokyocabinet-1.4.48/man/tcftest.1.manhelp tokyocabinet-1.4.48/man/tcftest.1
---- tokyocabinet-1.4.48/man/tcftest.1.manhelp 2013-05-19 11:20:58.078404514 +0200
-+++ tokyocabinet-1.4.48/man/tcftest.1 2013-05-19 11:21:48.949426514 +0200
-@@ -61,6 +61,8 @@ Options feature the following.
- .br
- \fB\-rl\fR : set the length of values at random.
- .br
-+\fB\-ru\fR : perform random operation on random key.
-+.br
- .RE
- .PP
- This command returns 0 on success, another on failure.
-diff -up tokyocabinet-1.4.48/man/tctmgr.1.manhelp tokyocabinet-1.4.48/man/tctmgr.1
---- tokyocabinet-1.4.48/man/tctmgr.1.manhelp 2013-05-19 11:27:12.273660237 +0200
-+++ tokyocabinet-1.4.48/man/tctmgr.1 2013-05-19 11:27:20.780632188 +0200
-@@ -122,10 +122,6 @@ Options feature the following.
- .br
- \fB\-it \fItype\fR\fR : specify the index type among "lexical", "decimal", "token", "qgram", and "void".
- .br
--\fB\-cd\fR : create the number index instead of the string index.
--.br
--\fB\-cv\fR : remove the existing index.
--.br
- \fB\-sc\fR : normalize keys as lower cases.
- .br
- .RE
-diff -up tokyocabinet-1.4.48/man/tcumttest.1.manhelp tokyocabinet-1.4.48/man/tcumttest.1
---- tokyocabinet-1.4.48/man/tcumttest.1.manhelp 2013-05-19 11:38:38.097051333 +0200
-+++ tokyocabinet-1.4.48/man/tcumttest.1 2013-05-19 11:43:22.167069021 +0200
-@@ -9,12 +9,12 @@ The command `\fBtcumttest\fR' is a utili
- .PP
- .RS
- .br
--\fBtcumttest combo \fR[\fB\-rnd\fR]\fB \fItnum\fB \fIrnum\fB \fR[\fB\fIbnum\fB\fR]\fB\fR
-+\fBtcumttest combo \fR[\fB\-rnd\fR]\fB \fItnum\fB \fIrnum\fB \fR[\fB\fIbnum\fB\fR]\fB\fR \fR[\fB\-tr\fB\fR]\fB
- .RS
- Peform storing, retrieving, and removing in turn.
- .RE
- .br
--\fBtcumttest typical \fR[\fB\-nc\fR]\fB \fR[\fB\-rr \fInum\fB\fR]\fB \fItnum\fB \fIrnum\fB \fR[\fB\fIbnum\fB\fR]\fB\fR
-+\fBtcumttest typical \fR[\fB\-nc\fR]\fB \fR[\fB\-rr \fInum\fB\fR]\fB \fItnum\fB \fIrnum\fB \fR[\fB\fIbnum\fB\fR]\fB\fR \fR[\fB\-tr\fB\fR]\fB
- .RS
- Perform typical operations selected at random.
- .RE
-@@ -29,6 +29,8 @@ Options feature the following.
- .br
- \-rr \fInum\fR : specifiy the ratio of reading operation by percentage.
- .br
-+\fB\-tr\fR : use on\-memory tree database object.
-+.br
- .RE
- .PP
- This command returns 0 on success, another on failure.
-diff -up tokyocabinet-1.4.48/tctmgr.c.manhelp tokyocabinet-1.4.48/tctmgr.c
-diff -up tokyocabinet-1.4.48/tcucodec.c.manhelp tokyocabinet-1.4.48/tcucodec.c
---- tokyocabinet-1.4.48/tcucodec.c.manhelp 2013-05-19 11:29:49.168261576 +0200
-+++ tokyocabinet-1.4.48/tcucodec.c 2013-05-19 11:34:28.335588929 +0200
-@@ -126,7 +126,7 @@ static void usage(void){
- fprintf(stderr, " %s bzip [-d] [file]\n", g_progname);
- fprintf(stderr, " %s xml [-d] [-br] [file]\n", g_progname);
- fprintf(stderr, " %s cstr [-d] [-js] [file]\n", g_progname);
-- fprintf(stderr, " %s ucs [-d] [-un] [file]\n", g_progname);
-+ fprintf(stderr, " %s ucs [-d] [-un] [-kw] [file]\n", g_progname);
- fprintf(stderr, " %s hash [-crc] [-ch num] [file]\n", g_progname);
- fprintf(stderr, " %s cipher [-key str] [file]\n", g_progname);
- fprintf(stderr, " %s date [-ds str] [-jl num] [-wf] [-rf]\n", g_progname);