aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/vlc-htsp-plugin/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/vlc-htsp-plugin/APKBUILD')
-rw-r--r--unmaintained/vlc-htsp-plugin/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/unmaintained/vlc-htsp-plugin/APKBUILD b/unmaintained/vlc-htsp-plugin/APKBUILD
new file mode 100644
index 0000000000..c8223299de
--- /dev/null
+++ b/unmaintained/vlc-htsp-plugin/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=vlc-htsp-plugin
+pkgver=20140304
+_id=9beb30a2d77e9d11f26e2868eca134e6734abb2e
+pkgrel=0
+pkgdesc="Plugin for VLC to access TVHeadend via HTSP"
+url="https://github.com/BtbN/vlc-htsp-plugin"
+arch="all"
+license="GPL"
+depends=""
+depends_dev=""
+makedepends="vlc-dev"
+install=""
+subpackages=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/BtbN/vlc-htsp-plugin/archive/$_id.tar.gz
+ support-bb-install.patch"
+
+_builddir="$srcdir"/$pkgname-$_id
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="d6c04c3ea63d1ffd5e41b04d72d91090 vlc-htsp-plugin-20140304.tar.gz
+c54a463f5a153ad537803f69af479ff6 support-bb-install.patch"
+sha256sums="e02b4544b62b4a11f0299e677497735dfda755002ce709ee74777631bd2e2e87 vlc-htsp-plugin-20140304.tar.gz
+27caf87352c10b3a0cc804cb9cdd8a27afba986df5b36576513683d9f12f32ac support-bb-install.patch"
+sha512sums="cf5cfc01760f388fcd754c57c3c397ddd95c81caaa8283922ddd0789166e59fe8a128bd755a2eb3bda19874ad18fa71795f26eab8e6454693018535364b6fb47 vlc-htsp-plugin-20140304.tar.gz
+655bee8c2cd1deaee0cef100dfdb8aa29d27eae6e21b431915eafab4786aaae6b231a69a31397fa58ef98b8839f9df42091a61311da8e8543f8f6313c8403267 support-bb-install.patch"