aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/pptpclient/APKBUILD32
-rw-r--r--unmaintained/pptpclient/pptpclient-uclibc.patch21
2 files changed, 0 insertions, 53 deletions
diff --git a/unmaintained/pptpclient/APKBUILD b/unmaintained/pptpclient/APKBUILD
deleted file mode 100644
index 757fff26b8..0000000000
--- a/unmaintained/pptpclient/APKBUILD
+++ /dev/null
@@ -1,32 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=pptpclient
-pkgver=1.7.2
-pkgrel=1
-pkgdesc="Client for the proprietary Microsoft Point-to-Point Tunneling Protocol, PPTP."
-url="http://pptpclient.sourceforge.net/"
-arch="all"
-license="GPL"
-depends="ppp iproute2"
-makedepends="perl"
-subpackages="$pkgname-doc"
-source="http://downloads.sourceforge.net/sourceforge/$pkgname/pptp-$pkgver.tar.gz
- pptpclient-uclibc.patch"
-
-prepare() {
- cd "$srcdir"/pptp-$pkgver
- patch -p1 -i "$srcdir"/pptpclient-uclibc.patch || return 1
- sed -i '/CFLAGS/d' Makefile
- sed -i 's|\/bin\/ip|\/usr\/sbin\/ip|g' routing.c
-}
-
-build() {
- cd "$srcdir"/pptp-$pkgver
- make || return 1
-}
-
-package() {
- cd "$srcdir"/pptp-$pkgver
- make DESTDIR="$pkgdir" install
-}
-md5sums="4c3d19286a37459a632c7128c92a9857 pptp-1.7.2.tar.gz
-34b643e4e4224e723f6a768018b46015 pptpclient-uclibc.patch"
diff --git a/unmaintained/pptpclient/pptpclient-uclibc.patch b/unmaintained/pptpclient/pptpclient-uclibc.patch
deleted file mode 100644
index aa9536e4df..0000000000
--- a/unmaintained/pptpclient/pptpclient-uclibc.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/pptp_compat.c b/pptp_compat.c
-index 1760a3b..6ebbea4 100644
---- a/pptp_compat.c
-+++ b/pptp_compat.c
-@@ -2,6 +2,7 @@
- *
- */
-
-+#if defined (__SVR4) && defined (__sun) /* Solaris */
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <fcntl.h>
-@@ -14,8 +15,6 @@
- #include <stdio.h>
- #include "util.h"
-
--
--#if defined (__SVR4) && defined (__sun) /* Solaris */
- /*
- * daemon implementation from uClibc
- */