aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/sword/00-fflush.patch12
-rw-r--r--unmaintained/sword/01-osisxhtml-super.patch16
-rw-r--r--unmaintained/sword/APKBUILD75
-rwxr-xr-xunmaintained/sword/sword.pre-install6
4 files changed, 109 insertions, 0 deletions
diff --git a/unmaintained/sword/00-fflush.patch b/unmaintained/sword/00-fflush.patch
new file mode 100644
index 0000000000..79f0649f65
--- /dev/null
+++ b/unmaintained/sword/00-fflush.patch
@@ -0,0 +1,12 @@
+diff --git a/utilities/installmgr.cpp b/utilities/installmgr.cpp
+index b705c25..132314a 100644
+--- a/utilities/installmgr.cpp
++++ b/utilities/installmgr.cpp
+@@ -73,6 +73,7 @@ virtual bool isUserDisclaimerConfirmed() const {
+ cout << "If you understand this and are willing to enable remote source features\n";
+ cout << "then type yes at the prompt\n\n";
+ cout << "enable? [no] ";
++ fflush(stdout);
+
+ char prompt[10];
+ fgets(prompt, 9, stdin);
diff --git a/unmaintained/sword/01-osisxhtml-super.patch b/unmaintained/sword/01-osisxhtml-super.patch
new file mode 100644
index 0000000000..dec1de72ee
--- /dev/null
+++ b/unmaintained/sword/01-osisxhtml-super.patch
@@ -0,0 +1,16 @@
+Fix superscripts in OSIS->xhtml translations, based on a fix
+by Karl Kleinpaste (revision 3375 in SVN)
+
+diff --git a/src/modules/filters/osisxhtml.cpp b/src/modules/filters/osisxhtml.cpp
+index fb743e2..759acc4 100644
+--- a/src/modules/filters/osisxhtml.cpp
++++ b/src/modules/filters/osisxhtml.cpp
+@@ -617,7 +617,7 @@ bool OSISXHTML::handleToken(SWBuf &buf, const char *token, BasicFilterUserData *
+ else if (type == "ol") {
+ outText("</span>", buf, u);
+ }
+- else if (type == "sup") {
++ else if (type == "super") {
+ outText("</sup>", buf, u);
+ }
+ else if (type == "sub") {
diff --git a/unmaintained/sword/APKBUILD b/unmaintained/sword/APKBUILD
new file mode 100644
index 0000000000..3a3f960cdc
--- /dev/null
+++ b/unmaintained/sword/APKBUILD
@@ -0,0 +1,75 @@
+# Contributor: Isaac Dunham <ibid.ag@gmail.com>
+# Maintainer: Isaac Dunham <ibid.ag@gmail.com>
+pkgname=sword
+pkgver=1.7.4
+pkgrel=6
+pkgdesc="Library for free Bible software"
+url="http://www.crosswire.org/sword/"
+arch="all"
+license="GPL2"
+depends=""
+# all are optional but desireable; clucene-dev could be replaced with
+# new --with-cxx11regex or --with-internalregex,
+# but currently c++11 regex leads to this error in diatheke:
+# terminate called after throwing an instance of 'std::runtime_error'
+# what(): locale::facet::_S_create_c_locale name not valid
+# Aborted
+# This might be fixed by the musl locale rework.
+# curl-dev is needed for standard packages.
+depends_dev="zlib-dev icu-dev curl-dev clucene-dev"
+makedepends="$depends_dev"
+pkggroups="sword"
+install="$pkgname.pre-install"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-utils"
+source="http://www.crosswire.org/ftpmirror/pub/sword/source/v1.7/sword-$pkgver.tar.gz
+ 00-fflush.patch
+ 01-osisxhtml-super.patch
+ "
+
+builddir="$srcdir"/sword-$pkgver
+build() {
+ cd "$builddir"
+ export CXXFLAGS="$CXXFLAGS -std=gnu++98"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --with-icu --with-zlib \
+ --with-curl --with-curl_sftp \
+ --with-clucene=/usr
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ mkdir -p -m775 "$pkgdir/var/lib/sword/modules" && \
+ mv "$pkgdir/usr/share/sword/mods.d" "$pkgdir/var/lib/sword/" && \
+ chown root:sword "$pkgdir"/var/lib/sword/mod* && \
+ chmod -R 0775 "$pkgdir/var/lib/sword/mods.d" && \
+ sed -e 's|\(DataPath=\).*|\1/var/lib/sword/|g' \
+ -i "$pkgdir/etc/sword.conf"
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+ for i in INSTALL README ChangeLog; do
+ install -Dm644 $i "$pkgdir"/usr/share/doc/sword/$i
+ done
+}
+
+lang() {
+ mkdir -p "$subpkgdir"/usr/share/sword/
+ mv "$pkgdir"/usr/share/sword/locales.d "$subpkgdir"/usr/share/sword/
+}
+
+utils() {
+ cd "$pkgdir"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv usr/bin/* "$subpkgdir"/usr/bin
+}
+
+sha512sums="4c8b183e613367364439cc7a8a842012f75180fccc8eb775b9af2dc4c10f39c152261d35f0aadaaa91a11df36ab1a4057c2edc50ea4b0b3bb0ab0a847ff68f75 sword-1.7.4.tar.gz
+6f6c13e7d04458e73d36c114017ad9e76e04c991adb8e457a0b55ce09fcaa95f33b2c26b73c2fd28591f07b69d3d03c1db6d08676001b3a45e0b66b22cb47dc0 00-fflush.patch
+98490104a0ef91497a3add3f078158b6fa57c73fc4028f26392716a0efb0957fd029a25239e04a2aa11ebd80583a23a9520a34d18bbf05ff54511d10bdd22bbe 01-osisxhtml-super.patch"
diff --git a/unmaintained/sword/sword.pre-install b/unmaintained/sword/sword.pre-install
new file mode 100755
index 0000000000..2ebce6d564
--- /dev/null
+++ b/unmaintained/sword/sword.pre-install
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+echo "Adding 'sword' group for installing SWORD modules systemwide"
+addgroup -S sword 2>/dev/null
+
+exit 0