From f90c15a50a5cefedf36bd7c043d5069b3652c092 Mon Sep 17 00:00:00 2001 From: Francesco Colista Date: Mon, 22 Aug 2016 08:41:09 +0000 Subject: community/thttpd: moved from testing --- community/thttpd/APKBUILD | 105 ++++++++++++++++++++++++++ community/thttpd/discreet.patch | 34 +++++++++ community/thttpd/forwarded-for.patch | 16 ++++ community/thttpd/getline.patch | 21 ++++++ community/thttpd/thttpd-makeweb-notsuid.patch | 12 +++ community/thttpd/thttpd-webgroup.patch | 13 ++++ community/thttpd/thttpd.conf | 8 ++ community/thttpd/thttpd.confd | 7 ++ community/thttpd/thttpd.initd | 27 +++++++ community/thttpd/thttpd.logrotated | 6 ++ community/thttpd/thttpd.post-install | 2 + community/thttpd/thttpd.pre-install | 8 ++ testing/thttpd/APKBUILD | 105 -------------------------- testing/thttpd/discreet.patch | 34 --------- testing/thttpd/forwarded-for.patch | 16 ---- testing/thttpd/getline.patch | 21 ------ testing/thttpd/thttpd-makeweb-notsuid.patch | 12 --- testing/thttpd/thttpd-webgroup.patch | 13 ---- testing/thttpd/thttpd.conf | 8 -- testing/thttpd/thttpd.confd | 7 -- testing/thttpd/thttpd.initd | 27 ------- testing/thttpd/thttpd.logrotated | 6 -- testing/thttpd/thttpd.post-install | 2 - testing/thttpd/thttpd.pre-install | 8 -- 24 files changed, 259 insertions(+), 259 deletions(-) create mode 100644 community/thttpd/APKBUILD create mode 100644 community/thttpd/discreet.patch create mode 100644 community/thttpd/forwarded-for.patch create mode 100644 community/thttpd/getline.patch create mode 100644 community/thttpd/thttpd-makeweb-notsuid.patch create mode 100644 community/thttpd/thttpd-webgroup.patch create mode 100644 community/thttpd/thttpd.conf create mode 100644 community/thttpd/thttpd.confd create mode 100644 community/thttpd/thttpd.initd create mode 100644 community/thttpd/thttpd.logrotated create mode 100644 community/thttpd/thttpd.post-install create mode 100644 community/thttpd/thttpd.pre-install delete mode 100644 testing/thttpd/APKBUILD delete mode 100644 testing/thttpd/discreet.patch delete mode 100644 testing/thttpd/forwarded-for.patch delete mode 100644 testing/thttpd/getline.patch delete mode 100644 testing/thttpd/thttpd-makeweb-notsuid.patch delete mode 100644 testing/thttpd/thttpd-webgroup.patch delete mode 100644 testing/thttpd/thttpd.conf delete mode 100644 testing/thttpd/thttpd.confd delete mode 100644 testing/thttpd/thttpd.initd delete mode 100644 testing/thttpd/thttpd.logrotated delete mode 100644 testing/thttpd/thttpd.post-install delete mode 100644 testing/thttpd/thttpd.pre-install diff --git a/community/thttpd/APKBUILD b/community/thttpd/APKBUILD new file mode 100644 index 0000000000..f2d91e3ce2 --- /dev/null +++ b/community/thttpd/APKBUILD @@ -0,0 +1,105 @@ +# Contributor: z3bra +# Maintainer: Francesco Colista +pkgname=thttpd +pkgver=2.27 +pkgrel=1 +pkgdesc="Simple, small, portable, fast, adn secure HTTP server" +url="http://www.acme.com/software/thttpd" +arch="all" +license="custom:BSD" +depends="" +depends_dev="" +makedepends="$depends_dev" +install="$pkgname.pre-install $pkgname.post-install" +subpackages="$pkgname-doc" +source="http://www.acme.com/software/$pkgname/$pkgname-$pkgver.tar.gz + thttpd.initd + thttpd.confd + thttpd.conf + thttpd.logrotated + thttpd-webgroup.patch + forwarded-for.patch + thttpd-makeweb-notsuid.patch + " + +_builddir=$srcdir/$pkgname-$pkgver +prepare() { + local i + cd "$_builddir" + for i in $source; do + case $i in + *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;; + esac + done + echo 'mkv video/x-matroska' >> mime_types.txt +} + +build() { + cd "$_builddir" + + ./configure --prefix=/usr --mandir=/usr/share/man + sed -e 's/^CFLAGS =/CFLAGS +=/' \ + -e '/^STATICFLAG =/c STATICFLAG =' \ + -i Makefile */Makefile || return 1 + + make || return 1 +} + +package() { + cd "$_builddir" + + mkdir -p $pkgdir/usr/share/man/man1 + + make \ + BINDIR="$pkgdir"/usr/sbin \ + WEBDIR="$pkgdir"/var/www/http \ + MANDIR="$pkgdir"/usr/share/man \ + WEBGROUP=www-data install || return 1 + + rm -rf "$pkgdir"/var/www/http/* + + install -m755 -D "$srcdir"/$pkgname.initd \ + "$pkgdir"/etc/init.d/$pkgname || return 1 + install -m644 -D "$srcdir"/$pkgname.confd \ + "$pkgdir"/etc/conf.d/$pkgname || return 1 + install -m644 -D "$srcdir"/$pkgname.conf \ + "$pkgdir"/etc/thttpd.conf || return 1 + install -m644 -D "$srcdir"/$pkgname.logrotated \ + "$pkgdir"/etc/logrotate.d/thttpd || return 1 + + install -d "$pkgdir"/var/log/thttpd + install -d "$pkgdir"/usr/share/licenses/"$pkgname" + head -n 26 thttpd.c > \ + "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE || return 1 + mkdir -p "$pkgdir/usr/share/doc/$pkgname" + cat > $pkgdir/usr/share/doc/$pkgname/README.alpine <\n\ + %d %s\n\ +-\n\ ++\n\ +

%d %s

\n", + status, title, status, title ); + add_response( hc, buf ); +@@ -769,11 +769,8 @@ + char buf[1000]; + + (void) my_snprintf( buf, sizeof(buf), "\ +-
\n\ +-
%s
\n\ + \n\ +-\n", +- SERVER_ADDRESS, EXPOSED_SERVER_SOFTWARE ); ++\n" ); + add_response( hc, buf ); + } + +@@ -2766,7 +2763,7 @@ + (void) fprintf( fp, "\ + \n\ + Index of %.80s\n\ +-\n\ ++\n\ +

Index of %.80s

\n\ +
\n\
+ mode  links  bytes  last-changed  name\n\
diff --git a/community/thttpd/forwarded-for.patch b/community/thttpd/forwarded-for.patch
new file mode 100644
index 0000000000..348eb00cf2
--- /dev/null
+++ b/community/thttpd/forwarded-for.patch
@@ -0,0 +1,16 @@
+diff -Naur old/libhttpd.c new/libhttpd.c
+--- old/libhttpd.c	2005-06-30 03:50:39.000000000 +1000
++++ new/libhttpd.c	2012-10-24 12:12:17.144560917 +1100
+@@ -2207,6 +2207,12 @@
+ 		if ( strcasecmp( cp, "keep-alive" ) == 0 )
+ 		    hc->keep_alive = 1;
+ 		}
++	    else if ( strncasecmp( buf, "X-Forwarded-For:", 16 ) == 0 )
++		{
++		cp = &buf[16];
++		cp += strspn( cp, " \t" );
++		inet_aton( cp, &(hc->client_addr.sa_in.sin_addr) );
++		}
+ #ifdef LOG_UNKNOWN_HEADERS
+ 	    else if ( strncasecmp( buf, "Accept-Charset:", 15 ) == 0 ||
+ 		      strncasecmp( buf, "Accept-Language:", 16 ) == 0 ||
diff --git a/community/thttpd/getline.patch b/community/thttpd/getline.patch
new file mode 100644
index 0000000000..1ec3946b10
--- /dev/null
+++ b/community/thttpd/getline.patch
@@ -0,0 +1,21 @@
+diff -Nur thttpd-2.25b.orig/extras/htpasswd.c thttpd-2.25b/extras/htpasswd.c
+--- thttpd-2.25b.orig/extras/htpasswd.c	2001-12-19 02:08:08.000000000 +0200
++++ thttpd-2.25b/extras/htpasswd.c	2010-04-11 14:43:31.037809054 +0300
+@@ -49,7 +49,7 @@
+     while((line[y++] = line[x++]));
+ }
+ 
+-static int getline(char *s, int n, FILE *f) {
++static int get_line(char *s, int n, FILE *f) {
+     register int i=0;
+ 
+     while(1) {
+@@ -189,7 +189,7 @@
+     strcpy(user,argv[2]);
+ 
+     found = 0;
+-    while(!(getline(line,MAX_STRING_LEN,f))) {
++    while(!(get_line(line,MAX_STRING_LEN,f))) {
+         if(found || (line[0] == '#') || (!line[0])) {
+             putline(tfp,line);
+             continue;
diff --git a/community/thttpd/thttpd-makeweb-notsuid.patch b/community/thttpd/thttpd-makeweb-notsuid.patch
new file mode 100644
index 0000000000..a1e0fa143f
--- /dev/null
+++ b/community/thttpd/thttpd-makeweb-notsuid.patch
@@ -0,0 +1,12 @@
+diff --git a/extras/Makefile.in b/extras/Makefile.in
+index a29780f..3e19a79 100644
+--- a/extras/Makefile.in
++++ b/extras/Makefile.in
+@@ -69,7 +69,6 @@ install:	all
+ 	rm -f $(BINDIR)/makeweb $(BINDIR)/htpasswd $(BINDIR)/syslogtocern
+ 	cp makeweb $(BINDIR)/makeweb
+ 	chgrp $(WEBGROUP) $(BINDIR)/makeweb
+-	chmod 2755 $(BINDIR)/makeweb
+ 	cp htpasswd $(BINDIR)/htpasswd
+ 	cp syslogtocern $(BINDIR)/syslogtocern
+ 	rm -f $(MANDIR)/man1/makeweb.1
diff --git a/community/thttpd/thttpd-webgroup.patch b/community/thttpd/thttpd-webgroup.patch
new file mode 100644
index 0000000000..fb493c88f4
--- /dev/null
+++ b/community/thttpd/thttpd-webgroup.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index ddd5f9a..d40fd6a 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -40,7 +40,7 @@ WEBDIR = $(prefix)/www
+ # CONFIGURE: The group that the web directory belongs to.  This is so that
+ # the makeweb program can be installed set-group-id to that group, and make
+ # subdirectories.  If you're not going to use makeweb, ignore this.
+-WEBGROUP =	www
++WEBGROUP =	www-data
+ 
+ # CONFIGURE: Directory for CGI executables.
+ CGIBINDIR =	$(WEBDIR)/cgi-bin
diff --git a/community/thttpd/thttpd.conf b/community/thttpd/thttpd.conf
new file mode 100644
index 0000000000..3623b89899
--- /dev/null
+++ b/community/thttpd/thttpd.conf
@@ -0,0 +1,8 @@
+dir=/var/www/http
+vhost
+chroot
+user=thttpd
+cgipat=**.cgi
+logfile=/var/log/thttpd/thttpd.log
+pidfile=/var/run/thttpd.pid
+charset=utf-8
diff --git a/community/thttpd/thttpd.confd b/community/thttpd/thttpd.confd
new file mode 100644
index 0000000000..ad09531fe1
--- /dev/null
+++ b/community/thttpd/thttpd.confd
@@ -0,0 +1,7 @@
+# Sample conf.d file for alpine linux
+
+#
+# Specify daemon options here.
+#
+
+sample_opts="-C /etc/thttpd.conf"
diff --git a/community/thttpd/thttpd.initd b/community/thttpd/thttpd.initd
new file mode 100644
index 0000000000..5ba5247b6d
--- /dev/null
+++ b/community/thttpd/thttpd.initd
@@ -0,0 +1,27 @@
+#!/sbin/openrc-run
+# init.d file for thttpd
+
+name=thttpd
+daemon=/usr/sbin/$name
+
+depend() {
+	need net
+	after firewall
+}
+
+start() {
+	ebegin "Starting ${name}"
+		start-stop-daemon --start --quiet \
+			--pidfile /var/run/${name}.pid \
+			--exec ${daemon} -- ${sample_opts}
+	eend $?
+}
+
+stop() {
+	ebegin "Stopping ${name}"
+		start-stop-daemon --stop --quiet \
+			--pidfile /var/run/$name.pid \
+			--exec ${daemon}
+	eend $?
+}
+
diff --git a/community/thttpd/thttpd.logrotated b/community/thttpd/thttpd.logrotated
new file mode 100644
index 0000000000..cbc559fb33
--- /dev/null
+++ b/community/thttpd/thttpd.logrotated
@@ -0,0 +1,6 @@
+/var/log/thttpd/*log {
+	missingok
+	postrotate
+        /etc/init.d/thttpd restart >/dev/null
+	endscript
+}
diff --git a/community/thttpd/thttpd.post-install b/community/thttpd/thttpd.post-install
new file mode 100644
index 0000000000..039e4d0069
--- /dev/null
+++ b/community/thttpd/thttpd.post-install
@@ -0,0 +1,2 @@
+#!/bin/sh
+exit 0
diff --git a/community/thttpd/thttpd.pre-install b/community/thttpd/thttpd.pre-install
new file mode 100644
index 0000000000..47dd3b0663
--- /dev/null
+++ b/community/thttpd/thttpd.pre-install
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+addgroup -S -g 82 www-data 2>/dev/null
+adduser -S -D -H -h /var/www/localhost/htdocs -s /sbin/nologin \
+        -g thttpd thttpd 2>/dev/null
+addgroup thttpd www-data 2>/dev/null
+
+exit 0
diff --git a/testing/thttpd/APKBUILD b/testing/thttpd/APKBUILD
deleted file mode 100644
index f2d91e3ce2..0000000000
--- a/testing/thttpd/APKBUILD
+++ /dev/null
@@ -1,105 +0,0 @@
-# Contributor: z3bra 
-# Maintainer: Francesco Colista 
-pkgname=thttpd
-pkgver=2.27
-pkgrel=1
-pkgdesc="Simple, small, portable, fast, adn secure HTTP server"
-url="http://www.acme.com/software/thttpd"
-arch="all"
-license="custom:BSD"
-depends=""
-depends_dev=""
-makedepends="$depends_dev"
-install="$pkgname.pre-install $pkgname.post-install"
-subpackages="$pkgname-doc"
-source="http://www.acme.com/software/$pkgname/$pkgname-$pkgver.tar.gz
-        thttpd.initd
-        thttpd.confd
-        thttpd.conf
-        thttpd.logrotated
-	thttpd-webgroup.patch
-        forwarded-for.patch
-	thttpd-makeweb-notsuid.patch
-        "
-
-_builddir=$srcdir/$pkgname-$pkgver
-prepare() {
-    local i
-    cd "$_builddir"
-    for i in $source; do
-        case $i in
-            *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
-        esac
-    done
-    echo 'mkv       video/x-matroska' >> mime_types.txt
-}
-
-build() {
-    cd "$_builddir"
-
-    ./configure --prefix=/usr --mandir=/usr/share/man
-    sed -e 's/^CFLAGS =/CFLAGS +=/' \
-        -e '/^STATICFLAG =/c STATICFLAG =' \
-        -i Makefile */Makefile || return 1
-
-    make || return 1
-}
-
-package() {
-    cd "$_builddir"
-    
-    mkdir -p $pkgdir/usr/share/man/man1
-
-    make \
-        BINDIR="$pkgdir"/usr/sbin \
-        WEBDIR="$pkgdir"/var/www/http \
-        MANDIR="$pkgdir"/usr/share/man \
-        WEBGROUP=www-data install || return 1
-
-    rm -rf "$pkgdir"/var/www/http/*
-
-    install -m755 -D "$srcdir"/$pkgname.initd \
-        "$pkgdir"/etc/init.d/$pkgname || return 1
-    install -m644 -D "$srcdir"/$pkgname.confd \
-        "$pkgdir"/etc/conf.d/$pkgname || return 1
-    install -m644 -D "$srcdir"/$pkgname.conf \
-        "$pkgdir"/etc/thttpd.conf || return 1
-    install -m644 -D "$srcdir"/$pkgname.logrotated \
-        "$pkgdir"/etc/logrotate.d/thttpd || return 1
-
-    install -d "$pkgdir"/var/log/thttpd
-    install -d "$pkgdir"/usr/share/licenses/"$pkgname"
-    head -n 26 thttpd.c > \
-    	"$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE || return 1
-    mkdir -p "$pkgdir/usr/share/doc/$pkgname"
-    cat > $pkgdir/usr/share/doc/$pkgname/README.alpine <\n\
- %d %s\n\
--\n\
-+\n\
- 

%d %s

\n", - status, title, status, title ); - add_response( hc, buf ); -@@ -769,11 +769,8 @@ - char buf[1000]; - - (void) my_snprintf( buf, sizeof(buf), "\ --
\n\ --
%s
\n\ - \n\ --\n", -- SERVER_ADDRESS, EXPOSED_SERVER_SOFTWARE ); -+\n" ); - add_response( hc, buf ); - } - -@@ -2766,7 +2763,7 @@ - (void) fprintf( fp, "\ - \n\ - Index of %.80s\n\ --\n\ -+\n\ -

Index of %.80s

\n\ -
\n\
- mode  links  bytes  last-changed  name\n\
diff --git a/testing/thttpd/forwarded-for.patch b/testing/thttpd/forwarded-for.patch
deleted file mode 100644
index 348eb00cf2..0000000000
--- a/testing/thttpd/forwarded-for.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -Naur old/libhttpd.c new/libhttpd.c
---- old/libhttpd.c	2005-06-30 03:50:39.000000000 +1000
-+++ new/libhttpd.c	2012-10-24 12:12:17.144560917 +1100
-@@ -2207,6 +2207,12 @@
- 		if ( strcasecmp( cp, "keep-alive" ) == 0 )
- 		    hc->keep_alive = 1;
- 		}
-+	    else if ( strncasecmp( buf, "X-Forwarded-For:", 16 ) == 0 )
-+		{
-+		cp = &buf[16];
-+		cp += strspn( cp, " \t" );
-+		inet_aton( cp, &(hc->client_addr.sa_in.sin_addr) );
-+		}
- #ifdef LOG_UNKNOWN_HEADERS
- 	    else if ( strncasecmp( buf, "Accept-Charset:", 15 ) == 0 ||
- 		      strncasecmp( buf, "Accept-Language:", 16 ) == 0 ||
diff --git a/testing/thttpd/getline.patch b/testing/thttpd/getline.patch
deleted file mode 100644
index 1ec3946b10..0000000000
--- a/testing/thttpd/getline.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -Nur thttpd-2.25b.orig/extras/htpasswd.c thttpd-2.25b/extras/htpasswd.c
---- thttpd-2.25b.orig/extras/htpasswd.c	2001-12-19 02:08:08.000000000 +0200
-+++ thttpd-2.25b/extras/htpasswd.c	2010-04-11 14:43:31.037809054 +0300
-@@ -49,7 +49,7 @@
-     while((line[y++] = line[x++]));
- }
- 
--static int getline(char *s, int n, FILE *f) {
-+static int get_line(char *s, int n, FILE *f) {
-     register int i=0;
- 
-     while(1) {
-@@ -189,7 +189,7 @@
-     strcpy(user,argv[2]);
- 
-     found = 0;
--    while(!(getline(line,MAX_STRING_LEN,f))) {
-+    while(!(get_line(line,MAX_STRING_LEN,f))) {
-         if(found || (line[0] == '#') || (!line[0])) {
-             putline(tfp,line);
-             continue;
diff --git a/testing/thttpd/thttpd-makeweb-notsuid.patch b/testing/thttpd/thttpd-makeweb-notsuid.patch
deleted file mode 100644
index a1e0fa143f..0000000000
--- a/testing/thttpd/thttpd-makeweb-notsuid.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/extras/Makefile.in b/extras/Makefile.in
-index a29780f..3e19a79 100644
---- a/extras/Makefile.in
-+++ b/extras/Makefile.in
-@@ -69,7 +69,6 @@ install:	all
- 	rm -f $(BINDIR)/makeweb $(BINDIR)/htpasswd $(BINDIR)/syslogtocern
- 	cp makeweb $(BINDIR)/makeweb
- 	chgrp $(WEBGROUP) $(BINDIR)/makeweb
--	chmod 2755 $(BINDIR)/makeweb
- 	cp htpasswd $(BINDIR)/htpasswd
- 	cp syslogtocern $(BINDIR)/syslogtocern
- 	rm -f $(MANDIR)/man1/makeweb.1
diff --git a/testing/thttpd/thttpd-webgroup.patch b/testing/thttpd/thttpd-webgroup.patch
deleted file mode 100644
index fb493c88f4..0000000000
--- a/testing/thttpd/thttpd-webgroup.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/Makefile b/Makefile
-index ddd5f9a..d40fd6a 100644
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -40,7 +40,7 @@ WEBDIR = $(prefix)/www
- # CONFIGURE: The group that the web directory belongs to.  This is so that
- # the makeweb program can be installed set-group-id to that group, and make
- # subdirectories.  If you're not going to use makeweb, ignore this.
--WEBGROUP =	www
-+WEBGROUP =	www-data
- 
- # CONFIGURE: Directory for CGI executables.
- CGIBINDIR =	$(WEBDIR)/cgi-bin
diff --git a/testing/thttpd/thttpd.conf b/testing/thttpd/thttpd.conf
deleted file mode 100644
index 3623b89899..0000000000
--- a/testing/thttpd/thttpd.conf
+++ /dev/null
@@ -1,8 +0,0 @@
-dir=/var/www/http
-vhost
-chroot
-user=thttpd
-cgipat=**.cgi
-logfile=/var/log/thttpd/thttpd.log
-pidfile=/var/run/thttpd.pid
-charset=utf-8
diff --git a/testing/thttpd/thttpd.confd b/testing/thttpd/thttpd.confd
deleted file mode 100644
index ad09531fe1..0000000000
--- a/testing/thttpd/thttpd.confd
+++ /dev/null
@@ -1,7 +0,0 @@
-# Sample conf.d file for alpine linux
-
-#
-# Specify daemon options here.
-#
-
-sample_opts="-C /etc/thttpd.conf"
diff --git a/testing/thttpd/thttpd.initd b/testing/thttpd/thttpd.initd
deleted file mode 100644
index 5ba5247b6d..0000000000
--- a/testing/thttpd/thttpd.initd
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/sbin/openrc-run
-# init.d file for thttpd
-
-name=thttpd
-daemon=/usr/sbin/$name
-
-depend() {
-	need net
-	after firewall
-}
-
-start() {
-	ebegin "Starting ${name}"
-		start-stop-daemon --start --quiet \
-			--pidfile /var/run/${name}.pid \
-			--exec ${daemon} -- ${sample_opts}
-	eend $?
-}
-
-stop() {
-	ebegin "Stopping ${name}"
-		start-stop-daemon --stop --quiet \
-			--pidfile /var/run/$name.pid \
-			--exec ${daemon}
-	eend $?
-}
-
diff --git a/testing/thttpd/thttpd.logrotated b/testing/thttpd/thttpd.logrotated
deleted file mode 100644
index cbc559fb33..0000000000
--- a/testing/thttpd/thttpd.logrotated
+++ /dev/null
@@ -1,6 +0,0 @@
-/var/log/thttpd/*log {
-	missingok
-	postrotate
-        /etc/init.d/thttpd restart >/dev/null
-	endscript
-}
diff --git a/testing/thttpd/thttpd.post-install b/testing/thttpd/thttpd.post-install
deleted file mode 100644
index 039e4d0069..0000000000
--- a/testing/thttpd/thttpd.post-install
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-exit 0
diff --git a/testing/thttpd/thttpd.pre-install b/testing/thttpd/thttpd.pre-install
deleted file mode 100644
index 47dd3b0663..0000000000
--- a/testing/thttpd/thttpd.pre-install
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/sh
-
-addgroup -S -g 82 www-data 2>/dev/null
-adduser -S -D -H -h /var/www/localhost/htdocs -s /sbin/nologin \
-        -g thttpd thttpd 2>/dev/null
-addgroup thttpd www-data 2>/dev/null
-
-exit 0
-- 
cgit v1.2.3