From a6f4bfc49f2f70271ffe44b7c2450f5b7478bda9 Mon Sep 17 00:00:00 2001 From: z3bra Date: Wed, 22 Oct 2014 17:32:48 +0200 Subject: testing/cv: new aport --- testing/cv/APKBUILD | 40 ++++++++++++++++++++++++++++++++++++++++ testing/cv/compress-tools.patch | 11 +++++++++++ 2 files changed, 51 insertions(+) create mode 100644 testing/cv/APKBUILD create mode 100644 testing/cv/compress-tools.patch (limited to 'testing') diff --git a/testing/cv/APKBUILD b/testing/cv/APKBUILD new file mode 100644 index 0000000000..c0fd220910 --- /dev/null +++ b/testing/cv/APKBUILD @@ -0,0 +1,40 @@ +# Contributor: z3bra +# Maintainer: +pkgname=cv +pkgver=0.5.1 +pkgrel=0 +pkgdesc="Linux tool to show progress for cp, rm, dd, ..." +url="https://github.com/Xfennec/cv" +arch="all" +license="GPL3" +depends="ncurses-dev" +depends_dev="" +makedepends="$depends_dev" +install="" +subpackages= +source="http://github.com/Xfennec/$pkgname/archive/v$pkgver.tar.gz" + +_builddir=$srcdir/$pkgname-$pkgver +prepare() { + local i + cd "$_builddir" + for i in $source; do + case $i in + *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;; + esac + done +} + +build() { + cd "$_builddir" + make +} + +package() { + cd "$_builddir" + make PREFIX=/usr DESTDIR=$pkgdir install +} + +md5sums="8ac0e1169428b23b46cf509cf30e8e5a v0.5.1.tar.gz" +sha256sums="d390a26a8db78366be8dfee93819135a106610ba7e3f6d94515c84d5803195d4 v0.5.1.tar.gz" +sha512sums="af12176cbf2806a411fb9be9709e51f59c34888689f96a46d64ecac0fc93d892673268b2a25253e46ca0dcf711325d67b94ffbe4033dbc3cf733d1a15b712863 v0.5.1.tar.gz" diff --git a/testing/cv/compress-tools.patch b/testing/cv/compress-tools.patch new file mode 100644 index 0000000000..696064e60b --- /dev/null +++ b/testing/cv/compress-tools.patch @@ -0,0 +1,11 @@ +--- cv.orig/cv.c ++++ cv/cv.c +@@ -44,7 +44,7 @@ + #include "sizes.h" + #include "hlist.h" + +-char *proc_names[] = {"cp", "mv", "dd", "tar", "gzip", "gunzip", "cat", "grep", "fgrep", "egrep", "cut", "sort", NULL}; ++char *proc_names[] = {"cp", "mv", "dd", "tar", "gzip", "gunzip", "cat", "grep", "fgrep", "egrep", "cut", "sort", "cpio", "xz", "bzip2", "bunzip2", NULL}; + char *proc_specifiq = NULL; + WINDOW *mainwin; + signed char flag_quiet = 0; -- cgit v1.2.3 From ed9dccdc2f3917ea45d352806a0701ef05ba5a3b Mon Sep 17 00:00:00 2001 From: z3bra Date: Wed, 22 Oct 2014 17:35:03 +0200 Subject: testing/detox: new aport --- testing/detox/APKBUILD | 43 +++++++++++++++++++++++++++++++++++++++++++ 1 file changed, 43 insertions(+) create mode 100644 testing/detox/APKBUILD (limited to 'testing') diff --git a/testing/detox/APKBUILD b/testing/detox/APKBUILD new file mode 100644 index 0000000000..c49183583b --- /dev/null +++ b/testing/detox/APKBUILD @@ -0,0 +1,43 @@ +# Contributor: z3bra +# Maintainer: +pkgname=detox +pkgver=1.2.0 +pkgrel=0 +pkgdesc="utility designed to clean up filenames" +url="http://detox.sourceforge.net/" +arch="all" +license="BSD" +depends="" +depends_dev="flex-dev" +makedepends="$depends_dev" +install="" +subpackages="$pkgname-doc" +source="saveas-http://sourceforge.net/projects/detox/files/detox/1.2.0/detox-1.2.0.tar.bz2/download/$pkgname-$pkgver.tar.bz2" + +_builddir=$srcdir/$pkgname-$pkgver +build() { + cd "$_builddir" + ./configure \ + --prefix=/usr \ + --sysconfdir=/etc \ + --infodir=/usr/share/info \ + --mandir=/usr/share/man \ + --datadir=/usr/share \ + make || return 1 +} + +package() { + cd "$_builddir" + + install -d -m 755 $pkgdir/etc + install -d -m 755 $pkgdir/usr/bin + install -d -m 755 $pkgdir/usr/share/detox + install -d -m 755 $pkgdir/usr/share/man/man1 + install -d -m 755 $pkgdir/usr/share/man/man5 + + make DESTDIR=$pkgdir install +} + +md5sums="da34c6bc3c68ce2fb008e25066e72927 detox-1.2.0.tar.bz2" +sha256sums="abfad90ee7d3e0fc53ce3b9da3253f9a800cdd92e3f8cc12a19394a7b1dcdbf8 detox-1.2.0.tar.bz2" +sha512sums="48c0060ed0538c26aeba444bf327f1e52ea47d0e696577deeb43304dfb960ee5abe984651948bfc67c51d7f15f9051df2a208acfe53a5778a7471460e87f639a detox-1.2.0.tar.bz2" -- cgit v1.2.3 From 7bdf6c04532bf8da169439a6122c25dce8b6ca14 Mon Sep 17 00:00:00 2001 From: z3bra Date: Wed, 22 Oct 2014 17:35:03 +0200 Subject: testing/httpup: new aport --- testing/httpup/10-getcwd.patch | 10 +++++++++ testing/httpup/APKBUILD | 49 ++++++++++++++++++++++++++++++++++++++++++ 2 files changed, 59 insertions(+) create mode 100644 testing/httpup/10-getcwd.patch create mode 100644 testing/httpup/APKBUILD (limited to 'testing') diff --git a/testing/httpup/10-getcwd.patch b/testing/httpup/10-getcwd.patch new file mode 100644 index 0000000000..c3acbeb38d --- /dev/null +++ b/testing/httpup/10-getcwd.patch @@ -0,0 +1,10 @@ +--- httpup-0.4.0k.orig/main.cpp ++++ httpup-0.4.0k/main.cpp +@@ -12,6 +12,7 @@ + #include + #include + #include ++#include + using namespace std; + + #include "httpup.h" diff --git a/testing/httpup/APKBUILD b/testing/httpup/APKBUILD new file mode 100644 index 0000000000..166573fe6e --- /dev/null +++ b/testing/httpup/APKBUILD @@ -0,0 +1,49 @@ +# Contributor: z3bra +# Maintainer: +pkgname=httpup +pkgver=0.4.0l +pkgrel=0 +pkgdesc="One way sync over http (CRUX port)" +url="http://jw.tks6.net/files/crux/${pkgname}_manual.html" +arch="all" +license="GPL" +depends="curl" +depends_dev="curl-dev" +makedepends="$depends_dev" +subpackages="httpup-doc" +source="http://jw.tks6.net/files/crux/$pkgname-$pkgver.tar.gz + 10-getcwd.patch" + +_builddir=$srcdir/$pkgname-$pkgver +prepare() { + local i + cd "$_builddir" + for i in $source; do + case $i in + *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;; + esac + done + + sed -i 's/usr/local/usr' Makefile +} + +build() { + cd "$_builddir" + make + +} + +package() { + cd "$_builddir" + + make DESTDIR=$pkgdir install + + install -Dm644 COPYING "$pkgdir"/usr/share/licenses/"$pkgname"/COPYING +} + +md5sums="c0e2973f0dbd7655dcbb5e5979ddc199 httpup-0.4.0l.tar.gz +a158568d4e6fe8cc5d5e3becc1508b31 10-getcwd.patch" +sha256sums="005079b7d96b23e27dd645492e21f9f93a9a3ebd2ad061069bc038180c04a549 httpup-0.4.0l.tar.gz +0f6ae9ef93cc835631dae836d3040deaf2f435b8bad6c4b5ea60bce36683b9d2 10-getcwd.patch" +sha512sums="8e4aab2abc0792de1c9274c2df5ff50e1362d18bcb94fb908e4c9b691de9bb557f39908be015ae436cf4335e54ac4536a7292a304eac4a39a1425d92e36a8fee httpup-0.4.0l.tar.gz +ba184e443539ddc935041e9cfc075bc8fc16df17329bc626ce6489ae754cee31906fa6339601c2e58333f44ac67fbfdce12b0eff602f83a234c206bfe649f774 10-getcwd.patch" -- cgit v1.2.3 From 85341eeec8c297a85a30024f88bab45e910cbe62 Mon Sep 17 00:00:00 2001 From: z3bra Date: Wed, 22 Oct 2014 17:35:04 +0200 Subject: testing/libcaca: new aport --- testing/libcaca/APKBUILD | 36 ++++++++++++++++++++++++++++++++++++ 1 file changed, 36 insertions(+) create mode 100644 testing/libcaca/APKBUILD (limited to 'testing') diff --git a/testing/libcaca/APKBUILD b/testing/libcaca/APKBUILD new file mode 100644 index 0000000000..50f7784774 --- /dev/null +++ b/testing/libcaca/APKBUILD @@ -0,0 +1,36 @@ +# Contributor: z3bra +# Maintainer: +pkgname=libcaca +pkgver=0.99 +_pkgver=beta19 +pkgrel=0 +pkgdesc="graphics library that outputs text instead of pixels" +url="http://caca.zoy.org/wiki/libcaca" +arch="all" +license="WTFPL" +options="libtool" +depends="" +depends_dev="" +makedepends="$depends_dev" +install="" +subpackages="$pkgname-dev $pkgname-doc" +source="http://caca.zoy.org/files/$pkgname/$pkgname-$pkgver.$_pkgver.tar.gz" + +_builddir=$srcdir/${pkgname}-${pkgver}.${_pkgver} + +build() { + cd "$_builddir" + ./configure --prefix=/usr || return 1 + make || return 1 +} + +package() { + cd "$_builddir" + + make DESTDIR=$pkgdir install + install COPYING -Dm644 $pkgdir/usr/share/licenses/$pkgname/LICENSE +} + +md5sums="a3d4441cdef488099f4a92f4c6c1da00 libcaca-0.99.beta19.tar.gz" +sha256sums="128b467c4ed03264c187405172a4e83049342cc8cc2f655f53a2d0ee9d3772f4 libcaca-0.99.beta19.tar.gz" +sha512sums="780fc7684d40207cc10df3f87d6d8f1d47ddfffa0e76e41a5ce671b82d5c7f090facb054c3d49ca7c4ea1a619625bb9085ce52f837f50792b4a2d776a4c68e15 libcaca-0.99.beta19.tar.gz" -- cgit v1.2.3 From 9893e419328455a048a6d498c93adbdfac098f36 Mon Sep 17 00:00:00 2001 From: z3bra Date: Wed, 22 Oct 2014 17:35:04 +0200 Subject: testing/markdown: new aport --- testing/markdown/APKBUILD | 34 ++++++++++++++++++++++++++++++++++ 1 file changed, 34 insertions(+) create mode 100644 testing/markdown/APKBUILD (limited to 'testing') diff --git a/testing/markdown/APKBUILD b/testing/markdown/APKBUILD new file mode 100644 index 0000000000..7140e07486 --- /dev/null +++ b/testing/markdown/APKBUILD @@ -0,0 +1,34 @@ +# Contributor: z3bra +# Maintainer: +pkgname=markdown +_pkgreal=Markdown +pkgver=1.0.1 +pkgrel=0 +pkgdesc="Text-to-HTML conversion tool for web writers" +url="http://daringfireball.net/projects/markdown/" +arch="noarch" +license="custom:BSD" +depends="perl" +depends_dev="" +makedepends="$depends_dev" +install="" +subpackages= +source="http://daringfireball.net/projects/downloads/Markdown_1.0.1.zip" + +_builddir=$srcdir/${_pkgreal}_${pkgver} + +build() { + cd "$_builddir" + pod2man "Markdown.pl" > "$_builddir/$pkgname.1" +} + +package() { + cd "$_builddir" + install -Dm755 "Markdown.pl" "${pkgdir}/usr/bin/${pkgname}" + install -Dm644 "License.text" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" + install -Dm644 "$pkgname.1" "$pkgdir/usr/share/man/man1/$pkgname.1" +} + +md5sums="f17b3c2b2830c6fd2fe0098226e59a2f Markdown_1.0.1.zip" +sha256sums="6520e9b6a58c5555e381b6223d66feddee67f675ed312ec19e9cee1b92bc0137 Markdown_1.0.1.zip" +sha512sums="962df356e641326fbf29cdedc36dafb5f04683f0b3f5eb1efb8e15994e1e000b5a6882c84f09db4a6f8f948811ebbe76759e27871c644e690884db31705eab1f Markdown_1.0.1.zip" -- cgit v1.2.3 From 42e2afa260722b6d96a3d13e97c0a065f8fd2c17 Mon Sep 17 00:00:00 2001 From: z3bra Date: Wed, 22 Oct 2014 17:35:04 +0200 Subject: testing/mpop: new aport --- testing/mpop/APKBUILD | 39 +++++++++++++++++++++++++++++++++++++++ 1 file changed, 39 insertions(+) create mode 100644 testing/mpop/APKBUILD (limited to 'testing') diff --git a/testing/mpop/APKBUILD b/testing/mpop/APKBUILD new file mode 100644 index 0000000000..783be40fa2 --- /dev/null +++ b/testing/mpop/APKBUILD @@ -0,0 +1,39 @@ +# Contributor: z3bra +# Maintainer: +pkgname=mpop +pkgver=1.0.29 +pkgrel=0 +pkgdesc="small an fast POP3 client" +url="http://$pkgname.sourceforge.net/" +arch="all" +license="GPL3" +depends= +depends_dev="gnutls-dev" +makedepends="$depends_dev" +install="" +subpackages="$pkgname-doc" +source="http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2" + +_builddir=$srcdir/$pkgname-$pkgver +build() { + cd "$_builddir" + ./configure \ + --build=$CBUILD \ + --host=$CHOST \ + --prefix=/usr \ + --sysconfdir=/etc \ + --mandir=/usr/share/man \ + --infodir=/usr/share/info \ + --localstatedir=/var \ + --with-ssl=gnutls \ + || return 1 + make || return 1 +} + +package() { + cd "$_builddir" + make DESTDIR="$pkgdir" install || return 1 +} +md5sums="468a145812123524b8ebc57f12ec4405 mpop-1.0.29.tar.bz2" +sha256sums="bd7409741629669969b176ed664e0adec449bf434b9f333e74fed534b28690b8 mpop-1.0.29.tar.bz2" +sha512sums="fbb55bf2c83024cc4397f6f59c6977a5f77ab697bbcc508a5160cd74047b4c0b717c76970d760f413356efd0527da0c9a129f34a664fea080ad39f5cef16ccb1 mpop-1.0.29.tar.bz2" -- cgit v1.2.3 From d5babbb8ef86ae55b002de1d4383a5a684f22e29 Mon Sep 17 00:00:00 2001 From: z3bra Date: Wed, 22 Oct 2014 17:35:04 +0200 Subject: testing/prt-get: new aport --- testing/prt-get/APKBUILD | 32 ++++++++++++++++++++++++++++++++ 1 file changed, 32 insertions(+) create mode 100644 testing/prt-get/APKBUILD (limited to 'testing') diff --git a/testing/prt-get/APKBUILD b/testing/prt-get/APKBUILD new file mode 100644 index 0000000000..1f23380918 --- /dev/null +++ b/testing/prt-get/APKBUILD @@ -0,0 +1,32 @@ +# Contributor: z3bra +# Maintainer: +pkgname=prt-get +pkgver=5.19 +pkgrel=1 +pkgdesc="Collection of scripts for CRUX, mainly oriented towards package and port management" +url="http://jw.smts.ch/files/crux/prt-get_quickstart.html" +arch="all" +license="Custom" +depends="" +depends_dev="" +makedepends="$depends_dev" +install="" +subpackages="" +source="http://jw.smts.ch/files/crux/$pkgname-$pkgver.tar.gz" + +_builddir=$srcdir/$pkgname-$pkgver + +build() { + cd "$_builddir" + ./configure --prefix=/usr --mandir=/usr/man + make +} + +package() { + cd "$_builddir" + make DESTDIR=$pkgdir install +} + +md5sums="a37751f1627a4e0125c8ffadfa85be80 prt-get-5.19.tar.gz" +sha256sums="987218709abf43cf6ce7a0941aff5802c3397d914a2485ebe3c3892e6062cd89 prt-get-5.19.tar.gz" +sha512sums="264e0c1166100a25713f5e29be4bfac58743d477f7bea02482289e92a500c4dbc29ed827a7718e6d741bf902450e4b4ad491a6ca09bf607137f086318c2cadcc prt-get-5.19.tar.gz" -- cgit v1.2.3 From 5b11fa3aaf8a3d8fa25fe30ea370f8a8f8dfbf3d Mon Sep 17 00:00:00 2001 From: z3bra Date: Wed, 22 Oct 2014 17:35:04 +0200 Subject: testing/thttpd: new aport --- testing/thttpd/APKBUILD | 96 ++++++++++++++++++++++++++++++++++++++ testing/thttpd/discreet.patch | 34 ++++++++++++++ testing/thttpd/forwarded-for.patch | 16 +++++++ testing/thttpd/getline.patch | 21 +++++++++ testing/thttpd/thttpd.conf | 8 ++++ testing/thttpd/thttpd.confd | 7 +++ testing/thttpd/thttpd.initd | 28 +++++++++++ testing/thttpd/thttpd.logrotated | 6 +++ testing/thttpd/thttpd.post-install | 4 ++ testing/thttpd/thttpd.pre-install | 4 ++ 10 files changed, 224 insertions(+) create mode 100644 testing/thttpd/APKBUILD create mode 100644 testing/thttpd/discreet.patch create mode 100644 testing/thttpd/forwarded-for.patch create mode 100644 testing/thttpd/getline.patch create mode 100644 testing/thttpd/thttpd.conf create mode 100644 testing/thttpd/thttpd.confd create mode 100644 testing/thttpd/thttpd.initd create mode 100644 testing/thttpd/thttpd.logrotated create mode 100644 testing/thttpd/thttpd.post-install create mode 100644 testing/thttpd/thttpd.pre-install (limited to 'testing') diff --git a/testing/thttpd/APKBUILD b/testing/thttpd/APKBUILD new file mode 100644 index 0000000000..220343234c --- /dev/null +++ b/testing/thttpd/APKBUILD @@ -0,0 +1,96 @@ +# Contributor: z3bra +# Maintainer: +pkgname=thttpd +pkgver=2.25b +pkgrel=0 +pkgdesc="Simple, small, portable, fast, adn secure HTTP server" +url="http://www.acme.com/software/thttpd" +arch="all" +license="custom:BSD" +depends="" +depends_dev="" +makedepends="$depends_dev" +install="$pkgname.pre-install $pkgname.post-install" +subpackages="$pkgname-doc" +source="http://www.acme.com/software/$pkgname/$pkgname-$pkgver.tar.gz + thttpd.initd + thttpd.confd + thttpd.conf + thttpd.logrotated + discreet.patch + forwarded-for.patch + getline.patch + " + +_builddir=$srcdir/$pkgname-$pkgver +prepare() { + local i + cd "$_builddir" + for i in $source; do + case $i in + *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;; + esac + done + echo 'mkv video/x-matroska' >> mime_types.txt +} + +build() { + cd "$_builddir" + + ./configure --prefix=/usr --mandir=/usr/share/man + sed -e 's/^CFLAGS =/CFLAGS +=/' \ + -e '/^STATICFLAG =/c STATICFLAG =' \ + -i Makefile */Makefile + + make +} + +package() { + cd "$_builddir" + + make \ + BINDIR="$pkgdir"/usr/sbin \ + WEBDIR="$pkgdir"/var/www/http \ + MANDIR="$pkgdir"/usr/share/man \ + WEBGROUP=root install + + rm -rf "$pkgdir"/var/www/http/* + + install -m755 -D "$srcdir"/$pkgname.initd \ + "$pkgdir"/etc/init.d/$pkgname || return 1 + install -m644 -D "$srcdir"/$pkgname.confd \ + "$pkgdir"/etc/conf.d/$pkgname || return 1 + install -m644 -D "$srcdir"/$pkgname.conf \ + "$pkgdir"/etc/thttpd.conf || return 1 + install -m644 -D "$srcdir"/$pkgname.logrotated \ + "$pkgdir"/etc/logrotate.d/thttpd || return 1 + + install -d "$pkgdir"/var/log/thttpd + install -d "$pkgdir"/usr/share/licenses/"$pkgname" + head -n 26 thttpd.c > "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE +} + +md5sums="156b249b3b0bcd48b06badd2db0d56c5 thttpd-2.25b.tar.gz +e73c541527e4784e1e234bab896fbe99 thttpd.initd +7e53378c3ab359beee6f1b3198bdb353 thttpd.confd +1828991ab3b4836247c94a7deb8947fa thttpd.conf +e29e38de0195bdbacec8daaa016cabfa thttpd.logrotated +055692a3037c35addc13e897ff8e5a02 discreet.patch +9976ae6a2bb06b076a100c05235a72b8 forwarded-for.patch +bf80d29e633eb0f6e3934649f9e010b2 getline.patch" +sha256sums="07719b08b1cff6a21c08697a7bcb4395425b07ee753106262fb62a03a7d32360 thttpd-2.25b.tar.gz +f20245ba64135f6a29cc3380d1940e2052e89edd56b12c4457009846b051bd15 thttpd.initd +25f55ad96c73d8c22117dd6ef331e85fed5a3ba78b4b0ec329832e82a4159e4e thttpd.confd +7fd376775c131474e123800b625fc43784c279b875061f4d5e3343742474355c thttpd.conf +774ac53a3ea2b9ccf08b8ce75bf0253f72e25054ed0cd0bae4e257526248376c thttpd.logrotated +da061d265b41d85aa5036dc439225e3fe709599b881e44ed8837a3c00fc54e7f discreet.patch +eb3be98c65b8f9297867205772cd9939f526ac1c2227c24ba7e8ff754dd2216c forwarded-for.patch +ab054c6178c91213293e2ad5eacec4d76a43c2140cbd4e516480acba9146e1d5 getline.patch" +sha512sums="52cbf3eb95ad868b60af2bd45620142cc8c6a80c3ff31ca853640a944d38594ac53e060b950bd028b3be49da97db5e10b41073d21b3f49b73a54ee01349a6b1d thttpd-2.25b.tar.gz +eeb042150c3b29b89c667cb8afc92d026e6b6cf772409dfb235fbd45823651b5e755cd93e3ae88304d77f171de8b3c46d558ac9c35eb9d2b640151b1761c89b7 thttpd.initd +9b4309c2bc88d11ce71d40ab813e9cbe78e4ec7368e3e98f35da1d5a324ee0630a6892b43f58f84490e2b534a573673b106a9d5dd406fedefb2a4c664e455aa1 thttpd.confd +691c4a4d455f9043ea2a188b8271db431924bd24d5083d153b422ff6e8fd99d43129a1d6af7b2f6515a52d4ee0e172848b4490b4cbe6337decd0c2332ab8fdd3 thttpd.conf +5b2800825583e93cf4be76e71d2840b9894c1779a810d562a0b6145cae0c7504dadfdc1e844f1611a48cca3b4518d41b47e41a68f33043d58ffde85f1e56e3f3 thttpd.logrotated +63f1f8cce5f29977dafd9dd364abc0e34bbf7049aef3a570efb96454fcf69fe6143d88e49640a52c58cbb6ad30d11dc2db5bd661fd1a6a26061ccc6913b1c117 discreet.patch +02c079ca104f2358cd20756082657dca96f7a88cbeb611de81504f1581c5e085a7a2765ec55b6e0ae1948803afced85e8a45fc6deb2fef1ec5ba1ba96ce68b4b forwarded-for.patch +503294520bd62170eae264ff1128f2b74d3d036d6c51b426e0a482f5d4a431f681f5076e6173ed04ee31065c042062759a3cc9208cf5c4a9c756ad806600635e getline.patch" diff --git a/testing/thttpd/discreet.patch b/testing/thttpd/discreet.patch new file mode 100644 index 0000000000..b427ecc2cb --- /dev/null +++ b/testing/thttpd/discreet.patch @@ -0,0 +1,34 @@ +diff -Naur old/libhttpd.c new/libhttpd.c +--- old/libhttpd.c 2012-04-27 14:24:50.971711600 +0200 ++++ new/libhttpd.c 2012-04-27 14:33:24.559135581 +0200 +@@ -744,7 +744,7 @@ + (void) my_snprintf( buf, sizeof(buf), "\ + \n\ + %d %s\n\ +-\n\ ++\n\ +

%d %s

\n", + status, title, status, title ); + add_response( hc, buf ); +@@ -769,11 +769,8 @@ + char buf[1000]; + + (void) my_snprintf( buf, sizeof(buf), "\ +-
\n\ +-
%s
\n\ + \n\ +-\n", +- SERVER_ADDRESS, EXPOSED_SERVER_SOFTWARE ); ++\n" ); + add_response( hc, buf ); + } + +@@ -2766,7 +2763,7 @@ + (void) fprintf( fp, "\ + \n\ + Index of %.80s\n\ +-\n\ ++\n\ +

Index of %.80s

\n\ +
\n\
+ mode  links  bytes  last-changed  name\n\
diff --git a/testing/thttpd/forwarded-for.patch b/testing/thttpd/forwarded-for.patch
new file mode 100644
index 0000000000..348eb00cf2
--- /dev/null
+++ b/testing/thttpd/forwarded-for.patch
@@ -0,0 +1,16 @@
+diff -Naur old/libhttpd.c new/libhttpd.c
+--- old/libhttpd.c	2005-06-30 03:50:39.000000000 +1000
++++ new/libhttpd.c	2012-10-24 12:12:17.144560917 +1100
+@@ -2207,6 +2207,12 @@
+ 		if ( strcasecmp( cp, "keep-alive" ) == 0 )
+ 		    hc->keep_alive = 1;
+ 		}
++	    else if ( strncasecmp( buf, "X-Forwarded-For:", 16 ) == 0 )
++		{
++		cp = &buf[16];
++		cp += strspn( cp, " \t" );
++		inet_aton( cp, &(hc->client_addr.sa_in.sin_addr) );
++		}
+ #ifdef LOG_UNKNOWN_HEADERS
+ 	    else if ( strncasecmp( buf, "Accept-Charset:", 15 ) == 0 ||
+ 		      strncasecmp( buf, "Accept-Language:", 16 ) == 0 ||
diff --git a/testing/thttpd/getline.patch b/testing/thttpd/getline.patch
new file mode 100644
index 0000000000..1ec3946b10
--- /dev/null
+++ b/testing/thttpd/getline.patch
@@ -0,0 +1,21 @@
+diff -Nur thttpd-2.25b.orig/extras/htpasswd.c thttpd-2.25b/extras/htpasswd.c
+--- thttpd-2.25b.orig/extras/htpasswd.c	2001-12-19 02:08:08.000000000 +0200
++++ thttpd-2.25b/extras/htpasswd.c	2010-04-11 14:43:31.037809054 +0300
+@@ -49,7 +49,7 @@
+     while((line[y++] = line[x++]));
+ }
+ 
+-static int getline(char *s, int n, FILE *f) {
++static int get_line(char *s, int n, FILE *f) {
+     register int i=0;
+ 
+     while(1) {
+@@ -189,7 +189,7 @@
+     strcpy(user,argv[2]);
+ 
+     found = 0;
+-    while(!(getline(line,MAX_STRING_LEN,f))) {
++    while(!(get_line(line,MAX_STRING_LEN,f))) {
+         if(found || (line[0] == '#') || (!line[0])) {
+             putline(tfp,line);
+             continue;
diff --git a/testing/thttpd/thttpd.conf b/testing/thttpd/thttpd.conf
new file mode 100644
index 0000000000..3df0a660b0
--- /dev/null
+++ b/testing/thttpd/thttpd.conf
@@ -0,0 +1,8 @@
+dir=/var/www/http
+vhost
+chroot
+user=nobody
+cgipat=**.cgi
+logfile=/var/log/thttpd/thttpd.log
+pidfile=/var/run/thttpd.pid
+charset=utf-8
diff --git a/testing/thttpd/thttpd.confd b/testing/thttpd/thttpd.confd
new file mode 100644
index 0000000000..ad09531fe1
--- /dev/null
+++ b/testing/thttpd/thttpd.confd
@@ -0,0 +1,7 @@
+# Sample conf.d file for alpine linux
+
+#
+# Specify daemon options here.
+#
+
+sample_opts="-C /etc/thttpd.conf"
diff --git a/testing/thttpd/thttpd.initd b/testing/thttpd/thttpd.initd
new file mode 100644
index 0000000000..bd869489ee
--- /dev/null
+++ b/testing/thttpd/thttpd.initd
@@ -0,0 +1,28 @@
+#!/sbin/runscript
+
+# init.d file for thttpd
+
+name=thttpd
+daemon=/usr/sbin/$name
+
+depend() {
+	need net
+	after firewall
+}
+
+start() {
+	ebegin "Starting ${name}"
+		start-stop-daemon --start --quiet \
+			--pidfile /var/run/${name}.pid \
+			--exec ${daemon} -- ${sample_opts}
+	eend $?
+}
+
+stop() {
+	ebegin "Stopping ${name}"
+		start-stop-daemon --stop --quiet \
+			--pidfile /var/run/$name.pid \
+			--exec ${daemon}
+	eend $?
+}
+
diff --git a/testing/thttpd/thttpd.logrotated b/testing/thttpd/thttpd.logrotated
new file mode 100644
index 0000000000..cbc559fb33
--- /dev/null
+++ b/testing/thttpd/thttpd.logrotated
@@ -0,0 +1,6 @@
+/var/log/thttpd/*log {
+	missingok
+	postrotate
+        /etc/init.d/thttpd restart >/dev/null
+	endscript
+}
diff --git a/testing/thttpd/thttpd.post-install b/testing/thttpd/thttpd.post-install
new file mode 100644
index 0000000000..0586fcd5c5
--- /dev/null
+++ b/testing/thttpd/thttpd.post-install
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+# add something which happends after install
+
diff --git a/testing/thttpd/thttpd.pre-install b/testing/thttpd/thttpd.pre-install
new file mode 100644
index 0000000000..46079e0c04
--- /dev/null
+++ b/testing/thttpd/thttpd.pre-install
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+# add something which happends before install
+
-- 
cgit v1.2.3


From bedf482409ee19658a026e8e2fcd58a0f759f6c1 Mon Sep 17 00:00:00 2001
From: z3bra 
Date: Wed, 22 Oct 2014 17:35:04 +0200
Subject: testing/toilet: new aport

---
 testing/toilet/APKBUILD | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
 create mode 100644 testing/toilet/APKBUILD

(limited to 'testing')

diff --git a/testing/toilet/APKBUILD b/testing/toilet/APKBUILD
new file mode 100644
index 0000000000..58d2f0baec
--- /dev/null
+++ b/testing/toilet/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: z3bra 
+# Maintainer:
+pkgname=toilet
+pkgver=0.3
+pkgrel=0
+pkgdesc="free replacement for the figlet utility"
+url="http://caca.zoy.org/wiki/toilet"
+arch="all"
+license="WTFPL"
+depends="libcaca"
+depends_dev="libcaca-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://caca.zoy.org/raw-attachment/wiki/$pkgname/$pkgname-$pkgver.tar.gz"
+
+_builddir=$srcdir/$pkgname-$pkgver
+
+build() {
+	cd "$_builddir"
+        ./configure --prefix=/usr || return 1
+        make DESTDIR=$pkgdir || return 1
+}
+
+package() {
+	cd "$_builddir"
+        make DESTDIR=$pkgdir install || return 1
+        install COPYING -Dm644 $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
+
+md5sums="9b72591cb22a30c42a3184b17cabca6f  toilet-0.3.tar.gz"
+sha256sums="89d4b530c394313cc3f3a4e07a7394fa82a6091f44df44dfcd0ebcb3300a81de  toilet-0.3.tar.gz"
+sha512sums="64b9389562a51e7dba6e3f1dd27c5340f90df25d8fbf1e041b539f5243b5b6b7af1ebf033a511053ad72a73908d496a1f3d14c4ac656425aefb8364a0664ceed  toilet-0.3.tar.gz"
-- 
cgit v1.2.3


From f004a086e0056d5a1e3d0156e1c0601105998cc4 Mon Sep 17 00:00:00 2001
From: z3bra 
Date: Wed, 22 Oct 2014 17:35:04 +0200
Subject: testing/toilet-font: new aport

---
 testing/toilet-font/APKBUILD | 45 ++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 45 insertions(+)
 create mode 100644 testing/toilet-font/APKBUILD

(limited to 'testing')

diff --git a/testing/toilet-font/APKBUILD b/testing/toilet-font/APKBUILD
new file mode 100644
index 0000000000..1c16154dcd
--- /dev/null
+++ b/testing/toilet-font/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: z3bra 
+# Maintainer:
+pkgname=toilet-font
+pkgver=1.0
+pkgrel=0
+pkgdesc="Additional asciiart fonts for toilet (adapted from figlet-fonts)"
+url="http://www.figlet.org/fontdb.cgi"
+arch="all"
+license="GPL"
+depends="toilet"
+arch="noarch"
+license="GPL"
+depends="toilet"
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages=
+source="ftp://ftp.figlet.org/pub/figlet/fonts/ours.tar.gz
+        ftp://ftp.figlet.org/pub/figlet/fonts/contributed.tar.gz
+        ftp://ftp.figlet.org/pub/figlet/fonts/international.tar.gz
+        ftp://ftp.figlet.org/pub/figlet/fonts/ms-dos.tar.gz
+        "
+
+package() {
+	find "$srcdir" -iname '*.flf' |
+	while ifs='' read target; do
+		dest="$pkgdir/usr/share/figlet/$(basename "$target")"
+		if [[ ! -e "$dest" ]]; then
+			install -Dm644 "$target" "$dest"
+		fi
+	done
+}
+
+md5sums="ecfc312b626df0d04936200d074d2508  ours.tar.gz
+6e2dec4499f7a7fe178522e02e0b6cd1  contributed.tar.gz
+b2d53f7e251014adcdb4d407c47f90ef  international.tar.gz
+49aa57ab989e8d952be037414b0bbbe4  ms-dos.tar.gz"
+sha256sums="10184c883faa63e91c8c7d99f100fe2f76195221ff8863d29c1beef88f666e69  ours.tar.gz
+2c569e052e638b28e4205023ae717f7b07e05695b728e4c80f4ce700354b18c8  contributed.tar.gz
+e6493f51c96f8671c29ab879a533c50b31ade681acfb59e50bae6b765e70c65a  international.tar.gz
+d3678a98b3b058ae4ded8525f51a1c53b3c6e6833793cf7cf98fcd9550ed7e70  ms-dos.tar.gz"
+sha512sums="a5bb4b650246c201c89d019b354e5dafff040552d4bfdfac2fe901fa413ccf768db4b58c397eb850066f0a8c7d876c46a69b55927a2bd22c3b918cf6d397b1e4  ours.tar.gz
+aa2acc332c4a8916acd4911a8779ac394bc610dda1af9bfd3e8e9713dace15a1115c360abdf83589608302b529f151f6221f0e5a1e9ad0465de5bd877dcb4943  contributed.tar.gz
+5480ccf5aef3147e2c24cca486a703ba27c03ce4b259a3f811a2aa6ebb2ff7510919438e2d4289a1a8d55a2e3b92451e7b35a4c18f6303dc51f9ee7e4fbc0657  international.tar.gz
+8824b21b054be50fb90e4a80e6f1ca554784a3884ac9c9e4104635a9d7c72b57d98e4070687ecd83cfe9c85cd3969eb1f24a1a3a05e49a2822a16a9f207decb9  ms-dos.tar.gz"
-- 
cgit v1.2.3


From e158a0f5f67c9fb95360c79f1b6357cfa4b4ba8b Mon Sep 17 00:00:00 2001
From: z3bra 
Date: Wed, 22 Oct 2014 17:35:04 +0200
Subject: testing/wendy: new aport

---
 testing/wendy/APKBUILD | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
 create mode 100644 testing/wendy/APKBUILD

(limited to 'testing')

diff --git a/testing/wendy/APKBUILD b/testing/wendy/APKBUILD
new file mode 100644
index 0000000000..d0c4e8a3df
--- /dev/null
+++ b/testing/wendy/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: z3bra 
+# Maintainer:
+pkgname=wendy
+pkgver=0.5
+pkgrel=0
+pkgdesc="Directory watcher based on inotify(7)"
+url="http://git.z3bra.org/cgit.cgi/wendy"
+arch="all"
+license="wtfpl"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="http://git.z3bra.org/cgit.cgi/wendy/snapshot/$pkgname-$pkgver.tar.gz"
+
+_builddir=$srcdir/$pkgname-$pkgver
+build() {
+	cd "$_builddir"
+	make
+}
+
+package() {
+	cd "$_builddir"
+	make PREFIX=/usr DESTDIR=$pkgdir install
+}
+
+md5sums="96a1e2351e20fa15386d1cb61f7390e4  wendy-0.5.tar.gz"
+sha256sums="316c6234846b1c228325fcc8bef4ad06e23c8f5dadf4dbbfda460c37f7dfeab1  wendy-0.5.tar.gz"
+sha512sums="e12529e9424526a382f1010e2e4d238cc10e4154c673bd6ba82f3d11ccec24f5dc14de51fc3038dc75dad5f34d58f43fc9eb48e4d263957488b5e891c45d7fdb  wendy-0.5.tar.gz"
-- 
cgit v1.2.3