# Contributor: Roberto Oliveira <robertoguimaraes8@gmail.com>
# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
pkgname=cpptest
pkgver=1.1.2
pkgrel=0
pkgdesc="Portable and powerful unit testing framework for handling automated tests in C++"
url="http://cpptest.sourceforge.net/"
arch="all"
license="LGPL"
subpackages="$pkgname-dev"
source="https://sourceforge.net/projects/cpptest/files/cpptest/cpptest-1.1.2/cpptest-1.1.2.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"

prepare() {
	default_prepare
	update_config_guess
}

build() {
	cd "$builddir"
	./configure --prefix=/usr
	make
}

check() {
	cd "$builddir"
	make check
}

package() {
	cd "$builddir"
	make install DESTDIR="$pkgdir"
}

sha512sums="da1030c69a5886e752b9ae08b65c501334c7d2d4abd2174190209ce11ed351239a615b9f7c5019ee601289523b2c21a1205d2042e59aea6c2882d77d636fc57a  cpptest-1.1.2.tar.gz"