# Contributor: Drew DeVault <sir@cmpwn.com>
# Maintainer: Leo <thinkabit.ukim@gmail.com>
pkgname=py3-hypothesis
pkgver=4.41.2
pkgrel=0
pkgdesc="Advanced property-based (QuickCheck-like) testing for Python"
url="https://hypothesis.works/"
arch="noarch"
license="MPL-2.0"
depends="py3-attrs"
makedepends="py3-setuptools"
checkdepends="py3-pytest py3-coverage py3-tz py3-numpy py3-dateutil py3-pexpect"
source="py-hypothesis-$pkgver.tar.gz::https://github.com/HypothesisWorks/hypothesis-python/archive/hypothesis-python-$pkgver.tar.gz
	attrs.patch
	"
builddir="$srcdir/hypothesis-hypothesis-python-$pkgver/hypothesis-python"

replaces="py-hypothesis" # Backwards compatibility
provides="py-hypothesis=$pkgver-r$pkgrel" # Backwards compatibility

build() {
	python3 setup.py build
}

check() {
	# In python3 mock is actually unittest.mock
	sed -e 's/from mock/from unittest.mock/' -i tests/cover/test_regressions.py
	sed -e 's/from mock/from unittest.mock/' -i tests/cover/test_reflection.py

	# Add variables that will be used by python to find the local
	# hypothesis build
	PYPATH="$PWD/build/lib"

	PYTHONPATH="$PYPATH" python3 -m pytest tests/cover
	PYTHONPATH="$PYPATH" python3 -m pytest tests/py3
	PYTHONPATH="$PYPATH" python3 -m pytest tests/datetime
	PYTHONPATH="$PYPATH" python3 -m pytest tests/numpy
}

package() {
	python3 setup.py install --prefix=/usr --root="$pkgdir"
}

sha512sums="bd8901e44f4c6937b8ad79c409b1e8430c14ffe67cade114534d163ef1c1f382195a52903958cccc3d52d98bd9b23f8b41ca68fa08a73b1b26fbb707364780d0  py-hypothesis-4.41.2.tar.gz
9ef9fd9f7076586221f79b677c05139188c6d7c37fbbddfdf28dd4a6ca18b36457d3481ee716fb11a2a84f2db0d53105be880b92ec09d8bfbb63f8b5323dab27  attrs.patch"