# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xfconf
pkgver=4.13.8
pkgrel=0
pkgdesc="Hierarchical configuration system for Xfce"
url="https://xfce.org/"
arch="all"
license="GPL-2.0-only"
options="!check" # Requires running dbus daemon.
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
makedepends="libxfce4util-dev intltool gtk-doc glib-dev dbus-dev dbus-glib-dev"
source="https://archive.xfce.org/src/xfce/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2"

build() {
	./configure \
		--build=$CBUILD \
		--host=$CHOST \
		--prefix=/usr \
		--sysconfdir=/etc \
		--libexecdir=/usr/lib \
		--localstatedir=/var \
		--disable-static \
		--enable-gtk-doc
	make
}

check() {
	make check
}

package() {
	make DESTDIR="$pkgdir" install
}

sha512sums="2b6afee1c9299e56e1576f93b34410c99b16109e83b0b34c4e13d952997d4812de6a6ab69f015c8f7fb8cf01e1b00b5d953261c3cbbfeab216c878aae3618f77  xfconf-4.13.8.tar.bz2"