# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=aspell
pkgver=0.60.6
_pkgmajorver=${pkgver%.*}
pkgrel=0
pkgdesc="A spell checker designed to eventually replace Ispell"
url="http://aspell.net/"
license="LGPL"
subpackages="$pkgname-dev $pkgname-doc"
depends="uclibc ncurses libgcc uclibc++"
makedepends="ncurses-dev uclibc++-dev"
install=
source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz
	libmath.patch"

build () 
{ 
	cd "$srcdir"/$pkgname-$pkgver
	export CXX=${CXX_UC:-g++-uc}

	./configure --prefix=/usr || return 1

	# we want add -lm to linker flag for libaspell so wil build that
	# separately. this is just an ugly workaround
	make libaspell.la LDFLAGS="$LDFLAGS -lm" || return 1
	make || return 1
	make DESTDIR="$pkgdir" install || return 1
	ln -s $pkgname-${_pkgmajorver} "$pkgdir"/usr/lib/$pkgname || return 1
}
md5sums="bc80f0198773d5c05086522be67334eb  aspell-0.60.6.tar.gz
715f4e138ab33b27201d90cbc98b4fb3  libmath.patch"