# Contributor: Timo Teras <timo.teras@iki.fi>
# Maintainer: Timo Teras <timo.teras@iki.fi>

pkgname=dahdi-linux
pkgver=2.7.0
pkgrel=0
pkgdesc="Firmware for Digium Asterisk Hardware Device Interface drivers"
url="http://www.asterisk.org"
arch="noarch"
license="GPL"
depends=
makedepends=
install=
subpackages="$pkgname-dev"
source="http://downloads.digium.com/pub/telephony/dahdi-linux/releases/$pkgname-$pkgver.tar.gz
	wget-tar.patch"

# We online install the firmwares in this package since those are common for all
# kernel flavors. We also install the headers for the -dev package.
#
# The kernel drivers themselves are built from separate build recipe.
prepare() {
	cd "$srcdir"/$pkgname-$pkgver
	for i in $source; do
		case $i in
		*.patch|*.diff) patch -p1 -i "$srcdir"/$i || return 1;;
		esac
	done
}

build() {
	return 0
}

package() {
	cd "$srcdir"/$pkgname-$pkgver
	make -j1 DESTDIR="$pkgdir" HOTPLUG_FIRMWARE=yes \
		install-include install-firmware 
}

md5sums="ac0d7ed711130e8038b304c5e2f96334  dahdi-linux-2.7.0.tar.gz
d72ac3aab69c427d69f657287c5d8475  wget-tar.patch"
sha256sums="7666e83ddbe0b71b34ada30940788bb289c2918e6b8618a65c82674a9da36427  dahdi-linux-2.7.0.tar.gz
badb18c563c8e58b26ff289e23dcfe0da8fcf3cfec566057208ebee3a8bc832e  wget-tar.patch"
sha512sums="3fc42d71379dfd898930369732be1a0dd0e2051a388910dd47ca14ea1a280dc6cb39bf9fffd4db774548b72d760b629749b753030092e32494958676b63b320e  dahdi-linux-2.7.0.tar.gz
ee2e272f28cdc31b93f734e8be1aa3ad9d2b486a41939625c6ce660278dc2eb9f86b8778004513950da61f815abe63386df8db587d727099fc1d23e326b7f8c3  wget-tar.patch"