# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=espeak
pkgver=1.40.02
pkgrel=0
pkgdesc="Speech synthesizer for English and other languages"
url="http://espeak.sourceforge.net/"
license="GPL-3"
subpackages="$pkgname-dev"
depends="uclibc uclibc++"
makedepends="uclibc++-dev"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver-source.zip
	$pkgname-$pkgver-uclibc++.patch"

build() {
	local s="$srcdir"/$pkgname-$pkgver-source
	cd "$s"
	for i in ../*.patch; do
		msg "Applying $i..."
		patch -p1 < $i || return 1
	done

	export CXX=g++-uc

	cd src
	make CXXFLAGS="${CXXFLAGS}" AUDIO=none all || return 1

	msg "Fixing byte order of phoneme data files"
	cd "$s"/platforms/big_endian
	make
	./espeak-phoneme-data "$s"/espeak-data
	cp -f phondata phonindex phontab "$s"/espeak-data

	cd "$s"/src
	make DESTDIR="$pkgdir" AUDIO=none install || return 1

	cd "$s"
	install -d "$pkgdir"/usr/share/espeak-data
	cp -r dictsource "$pkgdir"/usr/share/espeak-data
}

md5sums="708954b44c526e8174df8b88a6382738  espeak-1.40.02-source.zip
c13bb95088c5777b4d3e5ea10ca37517  espeak-1.40.02-uclibc++.patch"