# Maintainer: Carlo Landmeter <clandmeter at gmail.com>
pkgname=libiconv
pkgver=1.12
pkgrel=4
pkgdesc="GNU charset conversion library for libc which doesn't implement it"
url="http://www.gnu.org/software/libiconv"
arch="all"
license='LGPL'
depends=""
source="http://ftp.gnu.org/pub/gnu/libiconv/libiconv-1.12.tar.gz"
subpackages="$pkgname-doc $pkgname-dev"

build() {
	cd "$srcdir/$pkgname-$pkgver"
	#only build if we need it
	if [ "$ALPINE_LIBC" != "eglibc" ]; then
		./configure --prefix=/usr \
			--mandir=/usr/share/man
		make || return 1
	fi
}

package() {
	cd "$srcdir/$pkgname-$pkgver"
	#if we use eglibc we install dummy libiconv
	if [ "$ALPINE_LIBC" = "eglibc" ]; then
		mkdir -p "$pkgdir"/usr/include "$pkgdir"/usr/share/doc
	else
		make DESTDIR="$pkgdir/" install
	fi
}


md5sums="c2be282595751535a618ae0edeb8f648  libiconv-1.12.tar.gz"