# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lighttpd
pkgver=1.4.31
_streamver=2.2.0
pkgrel=0
pkgdesc="a secure, fast, compliant and very flexible web-server"
url="http://www.lighttpd.net/"
arch="all"
license="custom"
install="$pkgname.pre-install"
depends=
pkgusers="lighttpd"
pkggroups="lighttpd"
makedepends="flex pcre-dev openssl-dev zlib-dev bzip2-dev lua-dev pkgconfig
	automake autoconf openldap-dev libxml2-dev sqlite-dev libev-dev"
source="http://download.lighttpd.net/lighttpd/releases-1.4.x/$pkgname-$pkgver.tar.bz2
	http://h264.code-shop.com/download/lighttpd-1.4.18_mod_h264_streaming-$_streamver.tar.gz
	$pkgname.initd
	$pkgname.confd
	$pkgname.logrotate
	spawn-fcgi.confd
	spawn-fcgi.initd
	lighttpd.conf
	mime-types.conf
	mod_cgi.conf
	mod_fastcgi.conf
	mod_fastcgi_fpm.conf

	automake-1.12.patch
	"
subpackages="$pkgname-doc $pkgname-mod_auth $pkgname-mod_h264_streaming
	$pkgname-mod_webdav"

prepare() {
	cd "$srcdir"/$pkgname-$pkgver
	for i in $source; do
		case $i in
		*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
		esac
	done

	# copy over the mod-h264-streaming mod
	# http://h264.code-shop.com/trac/wiki/Mod-H264-Streaming-Lighttpd-Version2#DownloadLighttpd1.4.191.4.20andother1.4.x
	cp "$srcdir"/lighttpd-1.4.18/src/moov.* src/
	cp "$srcdir"/lighttpd-1.4.18/src/mod_h264_streaming.c src/

	cat >> src/Makefile.am <<__EOF__

lib_LTLIBRARIES += mod_h264_streaming.la
mod_h264_streaming_la_SOURCES = mod_h264_streaming.c moov.c
mod_h264_streaming_la_LDFLAGS = -module -export-dynamic -avoid-version -no-undefined
mod_h264_streaming_la_LIBADD = \$(common_libadd)
__EOF__
	aclocal -I m4 && autoconf && automake --add-missing
}

build() { 
	local i
	cd "$srcdir"/$pkgname-$pkgver
	./configure --prefix=/usr \
		--disable-dependency-tracking \
		--enable-lfs \
		--libdir=/usr/lib/lighttpd \
		--without-mysql \
		--without-attr \
		--without-kerberos5 \
		--without-fam \
		--with-webdav-props \
		--with-webdav-locks \
		--without-gdbm \
		--without-memcache \
		--with-bzip2 \
		--with-ldap \
		--with-openssl \
		--with-libev \
		--with-lua || return 1

	make
}

package() {
	cd "$srcdir"/$pkgname-$pkgver
	make DESTDIR="$pkgdir" install || return 1
	rm "$pkgdir"/usr/lib/lighttpd/*.la || return 1

	# create dirs
	install -d -m755 -o lighttpd -g lighttpd \
		"$pkgdir"/var/run/lighttpd/ \
		"$pkgdir"/var/log/lighttpd/ || return 1 
	install -d -m755 \
		"$pkgdir"/etc/lighttpd/ \
		"$pkgdir"/var/www/localhost/htdocs || return 1

	# lighttpd
	install -D -m755 "$srcdir"/lighttpd.initd "$pkgdir"/etc/init.d/lighttpd
	install -D -m644 "$srcdir"/lighttpd.confd "$pkgdir"/etc/conf.d/lighttpd
	install -D -m644 "$srcdir"/lighttpd.logrotate \
		"$pkgdir"/etc/logrotate.d/lighttpd
	
	# spawn-fcgi
	install -D -m755 "$srcdir"/spawn-fcgi.initd \
		"$pkgdir"/etc/init.d/spawn-fcgi
	install -D -m644 "$srcdir"/spawn-fcgi.confd \
		"$pkgdir"/etc/conf.d/spawn-fcgi

	# config files
	for i in lighttpd.conf mime-types.conf mod_cgi.conf mod_fastcgi.conf mod_fastcgi_fpm.conf; do
		install -m644 "$srcdir"/$i "$pkgdir"/etc/lighttpd/$i
	done
}

_mv_mod() {
	mkdir -p "$subpkgdir"/usr/lib/lighttpd
	while [ $# -gt 0 ]; do
		mv "$pkgdir"/usr/lib/lighttpd/$1.so \
			"$subpkgdir"/usr/lib/lighttpd/ || return 1
		shift
	done
}

mod_h264_streaming() {
	pkgdesc="H264 Streaming Module for lighttpd"
	url="http://h264.code-shop.com/trac"
	license="CCPL-nc-sa-3.0"
	replaces="lighttpd-h264_streaming"
	_mv_mod mod_h264_streaming
}

mod_auth() {
	pkgdesc="Authentication module for lighttpd"
	_mv_mod mod_auth
}

mod_webdav() {
	pkgdesc="WebDAV module for lighttpd"
	_mv_mod mod_webdav
}


md5sums="c718cc27658240d307b8a1d1c7c4bb54  lighttpd-1.4.31.tar.bz2
ac37885c881a058194405232e7737a7a  lighttpd-1.4.18_mod_h264_streaming-2.2.0.tar.gz
aa1f130f66607615143b2b497c55b177  lighttpd.initd
0dede109282bfe685bdec6b35f0e4b6b  lighttpd.confd
ad091c9157134890499f26d170352c9f  lighttpd.logrotate
1d925aed297ec4541fb230dd19e11bc1  spawn-fcgi.confd
2f177ba0a35fd1c683edef3453c20bc8  spawn-fcgi.initd
268bf5dd2c370ee5e119246775ac5640  lighttpd.conf
fef397e7bcf1b741dea211a555e1803c  mime-types.conf
9c1407e95f62ed22da66c4ef5f69c3b5  mod_cgi.conf
f3363e39832f1b6678468b482d121afb  mod_fastcgi.conf
aee5947a1abf380b0685a534ca384b42  mod_fastcgi_fpm.conf
c15606d3158d4010e6fa8e01409b40cf  automake-1.12.patch"