# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lksctp-tools
pkgver=1.0.15
pkgrel=0
pkgdesc="User-space access to Linux Kernel SCTP"
url="http://lksctp.sourceforge.net"
arch="all"
license="GPLv2 and GPLv2+ and LGPLv2 and MIT"
depends=""
depends_dev=""
makedepends="$depends_dev libtool automake autoconf"
install=""
subpackages="$pkgname-dev $pkgname-doc"
source="http://downloads.sourceforge.net/lksctp/lksctp-tools-$pkgver.tar.gz"

_builddir="$srcdir"/lksctp-tools-$pkgver
prepare() {
	local i
	cd "$_builddir"
	for i in $source; do
		case $i in
		*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
		esac
	done
	if ! [ -e configure ]; then
		./bootstrap
	fi
}

build() {
	cd "$_builddir"
	./configure --prefix=/usr \
		--disable-static \
		|| return 1
	make

}

package() {
	cd "$_builddir"
	make DESTDIR="$pkgdir" install || return 1
	rm "$pkgdir"/usr/lib/*.la "$pkgdir"/usr/lib/lksctp-tools/*.la
}

md5sums="d829677541fb41061e7f4d61f8413b07  lksctp-tools-1.0.15.tar.gz"
sha256sums="5ef2330c8dc6bc454c26f6e9fb53bbe5a6a8372740aebd1be8c326b526106e78  lksctp-tools-1.0.15.tar.gz"
sha512sums="ecf04e28c0517bf4c083af6474ee66dac75e672edd95d975755c0e1cf7e8d3d1353254c7b73054c56746564a6c7f164859fab4ead46f9084f70d34272e2aaa59  lksctp-tools-1.0.15.tar.gz"