# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-locale-maketext-fuzzy
pkgver=0.10
pkgrel=0
pkgdesc="Locale::Maketext::Fuzzy perl module"
url="http://search.cpan.org/dist/Locale-Maketext-Fuzzy/"
arch="noarch"
license="GPLv2 or Artistic"
depends="perl"
makedepends="perl-dev"
install=""
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/A/AU/AUDREYT/Locale-Maketext-Fuzzy-$pkgver.tar.gz"

_builddir="$srcdir"/Locale-Maketext-Fuzzy-$pkgver
prepare() {
	local i
	cd "$_builddir"
	for i in $source; do
		case $i in
		*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
		esac
	done
}

build() {
	cd "$_builddir"
	PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
	make && make test || return 1
}

package() {
	cd "$_builddir"
	make DESTDIR="$pkgdir" install || return 1
	find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}

md5sums="ff5621abe3b6a632bdf91932b4b69513  Locale-Maketext-Fuzzy-0.10.tar.gz"