# Automatically generated by apkbuild-cpan, template 1
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-test-leaktrace
_pkgreal=Test-LeakTrace
pkgver=0.15
pkgrel=1
pkgdesc="Traces memory leaks"
url="http://search.cpan.org/dist/Test-LeakTrace/"
arch="all"
license="GPL PerlArtistic"
cpandepends=""
cpanmakedepends="   "
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/G/GF/GFUJI/$_pkgreal-$pkgver.tar.gz"

_builddir="$srcdir/$_pkgreal-$pkgver"

prepare() {
	cd "$_builddir"
	export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
	PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}

build() {
	cd "$_builddir"
	export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
	make && make test
}

package() {
	cd "$_builddir"
	make DESTDIR="$pkgdir" install || return 1
	find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}

md5sums="5eac99e7882970f41886c3e0cec185d8  Test-LeakTrace-0.15.tar.gz"
sha256sums="efb8b58b6981efc6c9c4b4a3b550728f8c179f3c8d57c05724873011c08de65e  Test-LeakTrace-0.15.tar.gz"
sha512sums="664d1648cc9ce229456ca0c27430bdd36ba1d9bf6907afce6c612b90d6885aa6a71caeceb266aec1f843287e6bcda35ac28eab2ad6b662019c0fcb87d7f0d6be  Test-LeakTrace-0.15.tar.gz"