# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-text-csv
_pkgname=Text-CSV
pkgver=1.97
pkgrel=0
pkgdesc="Manipulate comma-separated value strings"
url="http://search.cpan.org/dist/Text-CSV/"
arch="noarch"
license="PerlArtistic GPL"
depends="perl"
makedepends="perl-dev"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/I/IS/ISHIGAKI/$_pkgname-$pkgver.tar.gz"

builddir="$srcdir/$_pkgname-$pkgver"

build() {
	cd "$builddir"
	PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
	make
}

check() {
	cd "$builddir"
	make test
}

package() {
	cd "$builddir"
	make DESTDIR="$pkgdir" install
	find "$pkgdir" -name '.packlist' -delete
	find "$pkgdir" -name '*.pod' -delete
}

sha512sums="3700acb49a563ba7e08d234a383a7d579761d67097cadac8a9cb166cc436756b58a7c4a4d2c7e690e57b3aee99ec3d36e7f05ee135ce29ad6d8034b4570583f3  Text-CSV-1.97.tar.gz"