# Contributor:
# Maintainer:
pkgname=hessling-editor
_pkgname=THE
pkgver=3.3_rc1
_pkgver=3.3RC1
pkgrel=1
pkgdesc="Powerful text editor modelled on the XEDIT with the best features of Kedit."
url="http://hessling-editor.sourceforge.net/"
arch="all"
license="GPL"
depends=""
depends_dev=
makedepends="ncurses-dev regina-rexx"
install=""
subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/$pkgname/$_pkgname-$_pkgver.tar.gz"

_builddir="$srcdir"/$_pkgname-$_pkgver
prepare() {
	local i
	cd "$_builddir"
	for i in $source; do
		case $i in
		*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
		esac
	done
}

build() {
	cd "$_builddir"
	./configure --with-rexx=regina --with-ncurses --prefix=/usr || return 1
	make all || return 1
}

package() {
	cd "$_builddir"
	make DESTDIR="$pkgdir" install || return 1
}

md5sums="e46b63e533bc458f6f701983b7f2150b  THE-3.3RC1.tar.gz"